Repo Help Please??

Discussion in 'iPod touch' started by Ulysses_609, May 5, 2008.

  1. Ulysses_609

    Ulysses_609 Member

    Joined:
    Jan 26, 2008
    Messages:
    246
    Likes Received:
    0
    Device:
    iPhone 4S (Black)
    Ok I've been trying to fix this for days now.......I'm pretty sure I have everything done right. But everytime I try to download my package it says package download failed! I dont know what is wrong, I've zipped the folder in a MAC readable, I've redone the hash many times, the size of it is correct. Can someone please tell me what is wrong with it? I will give rep to whoever can solve my problem. here is my repo: http://ulysses609.googlepages.com/repo.xml
  2. Axis

    Axis Super Moderator Staff Member

    Joined:
    Dec 2, 2007
    Messages:
    6,288
    Likes Received:
    133
    Device:
    iPhone 4S (White)
    Replace the everything from <key>install</key> down with what I have posted and you should be good to go.

    Code:
    <key>install</key>
              <array>
                <array>
                  <string>CopyPath</string>
                  <string>Vista/</string>
                  <string>~/Library/SummerBoard/Themes/Vista</string>
                </array>
              </array>
              <key>uninstall</key>
              <array>
                <array>
                  <string>RemovePath</string>
                  <string>~/Library/SummerBoard/Themes/Vista</string>
                </array>
              </array>
            </dict>
          </dict>
        </array>
      </dict>
    </plist>
    (Fix the spacing if need be.)

    For future reference:

    * Put a / after the theme's folder. For example "Vista/". (This is in the CopyPath)
    *instead of /private/var/... use this:

    ~/Library/SummerBoard/Themes... (In CopyPath & RemovePath.)

Share This Page