Remote Host Identification Changed

Discussion in 'iPod touch Firmware 1.1.4 Discussions' started by jwasafrog, Mar 23, 2008.

  1. jwasafrog

    jwasafrog New Member

    Joined:
    Dec 30, 2007
    Messages:
    13
    Likes Received:
    0
    Hey guys,

    I keep getting an SSH error when i try to connect to my ipod. I know there's a ton of SSH problem threads out there, but I haven't found a solution for this one.

    When i try to connect to my 1.1.4 i keep getting a "Remote Host Identification has Changed" error. I'm on a mac and using Fugu to connect. I have Cyberduck too and can't connect with that either.

    Also, I know i have the IP right and I have SSH and BossPrefs installed so I know SSH is on.

    Any help is appreciated.


    Oh, and if anyone knows how to fix the "package downloading failed" error with installer please let me know.
  2. cameleon1267

    cameleon1267 Member

    Joined:
    Oct 11, 2007
    Messages:
    494
    Likes Received:
    1
    Device:
    iPhone 4 (Black)
    go to the preference of fugu and erase all the know host list that should fix your problem.

    as for your error in the installer try to install the community source package.
  3. jwasafrog

    jwasafrog New Member

    Joined:
    Dec 30, 2007
    Messages:
    13
    Likes Received:
    0
    Thanks, the community sources thing worked great, but I'm still getting the same SSH error.
  4. cameleon1267

    cameleon1267 Member

    Joined:
    Oct 11, 2007
    Messages:
    494
    Likes Received:
    1
    Device:
    iPhone 4 (Black)
    try to connect using the terminal:

    ssh root@192.168.#.#

    and also you can check in the hidden folder on your mac : .ssh and search for the host file. Delete it (keep a copy somewhere else just in case) and try again fugu.
  5. jwasafrog

    jwasafrog New Member

    Joined:
    Dec 30, 2007
    Messages:
    13
    Likes Received:
    0
    Hmm, same error with termial plus it says the RSA host key has been changed.
  6. cameleon1267

    cameleon1267 Member

    Joined:
    Oct 11, 2007
    Messages:
    494
    Likes Received:
    1
    Device:
    iPhone 4 (Black)
    strange. if you erased the host file it shouldn't remember your ipod. I got this error sometime but I always fixed it this way. try to reboot both ipod and computer or set a different static ip adress for your ipod.
  7. jwasafrog

    jwasafrog New Member

    Joined:
    Dec 30, 2007
    Messages:
    13
    Likes Received:
    0
    Oh, ok, i get it. how do i get into the hidden folder and erase they key though?
  8. cameleon1267

    cameleon1267 Member

    Joined:
    Oct 11, 2007
    Messages:
    494
    Likes Received:
    1
    Device:
    iPhone 4 (Black)
    I used onyx software to enable the invisible folder then go to

    /users/yourusername/.ssh

    remove known_hosts

    backup the file just in case.

    but did you erase the list of known hosts in the preference of fugu ? because it should have the same effect.
  9. jwasafrog

    jwasafrog New Member

    Joined:
    Dec 30, 2007
    Messages:
    13
    Likes Received:
    0
    I did.... BUT i didn't realize you need to hit "save" before you close the preferences window.

    Please Register or Log in to view images



    Thank you very much. It's working fine now.
  10. cameleon1267

    cameleon1267 Member

    Joined:
    Oct 11, 2007
    Messages:
    494
    Likes Received:
    1
    Device:
    iPhone 4 (Black)
    ok cool.

Share This Page