regarding updating itunes to dload 3.0

Discussion in 'iPod touch Firmware 3.0' started by w1nner, Jun 17, 2009.

  1. w1nner

    w1nner New Member

    Joined:
    Jun 17, 2009
    Messages:
    3
    Likes Received:
    0
    Device:
    2G iPod touch
    i have windows xp pro 64 bit which officially the ipod touch is not compatible with. luckily i found a special package that somebody else made which allows you to sync and use your ipod touch on 64 bit xp. however the version of this pack is 8.0.1.11. unfortunatly you need a newer version which i think would fawk up my setup. lets say i used a different computer to upgrade to 3.0... if i tryed syncing my ipod with my xp 64 bit comp after upgrading would it still work?
  2. Axis

    Axis Super Moderator Staff Member

    Joined:
    Dec 2, 2007
    Messages:
    6,288
    Likes Received:
    133
    Device:
    iPhone 4S (White)
    That should work, no guarantee from me though.

Share This Page