iOS 4.0 quick question

Discussion in 'iOS Jailbreak & Cydia' started by Frostbite714, Apr 22, 2010.

  1. Frostbite714

    Frostbite714 Active Member

    Joined:
    Aug 18, 2008
    Messages:
    228
    Likes Received:
    46
    Device:
    iPhone 5S
    I know that not all of the 4.0 features will work on every device, but will I at least be able to run the 4.0 firmware on my FIRST gen ipod touch? Or if i cant, do you think there will be a way to get a jailbroken version for older devices?
  2. Chicken

    Chicken Retired Moderator

    Joined:
    Feb 17, 2008
    Messages:
    2,494
    Likes Received:
    7
    Device:
    iPhone 5S
    No, you will not be able to run it on your device.
  3. mitchell209

    mitchell209 Active Member

    Joined:
    Jan 21, 2009
    Messages:
    8,024
    Likes Received:
    5
    Device:
    iPhone 4 (Black)
    There may eventually be a way to get 4.0 on your iPod, but not officially.
  4. Ryan

    Ryan Well-Known Member

    Joined:
    Jan 19, 2008
    Messages:
    4,129
    Likes Received:
    28
    Device:
    Nexus 4
    Wouldnt get your hopes up, we have NEVER been able to port one devices firmware to another one :\
  5. personman

    personman Active Member

    Joined:
    May 1, 2008
    Messages:
    1,466
    Likes Received:
    16
    Device:
    iPhone 5S
    Actually, back before iTunes started checking FW for compatibility, you could run the iPhone 2G firmware on an iPod Touch 1st Generation. I did it a few times (don't remember exactly why I did though).
  6. mitchell209

    mitchell209 Active Member

    Joined:
    Jan 21, 2009
    Messages:
    8,024
    Likes Received:
    5
    Device:
    iPhone 4 (Black)
    Yeah, it sucks, but nobody has ever had a need to.

    Since they don't even have a 4.0 for the first gens, somebody may find some way to get them ported over.
  7. Shadowriver

    Shadowriver Active Member

    Joined:
    Jun 20, 2008
    Messages:
    1,467
    Likes Received:
    1
    Device:
    iPod touch
    Thats interesting, can you investigate this again? Perosnally i think it's impossible... why? you can read in my thread:

    http://www.ifans.com/forums/showthread.php?t=284216
  8. personman

    personman Active Member

    Joined:
    May 1, 2008
    Messages:
    1,466
    Likes Received:
    16
    Device:
    iPhone 5S
    At the moment, I'm in possession of a first gen iPod Touch 8GB but it's not mine and I already did a LOT of jailbreak stuff that I don't wanna lose. If the device decides to crash (not likely) or I can get my hands on another one, I'll try.
  9. ipodtouch123

    ipodtouch123 Member

    Joined:
    Apr 21, 2008
    Messages:
    441
    Likes Received:
    0
    Device:
    iPhone 3G (Black)
    i really don't think there will be one for first gen and even if there was, not many new features would be able to work for it anyways....
  10. personman

    personman Active Member

    Joined:
    May 1, 2008
    Messages:
    1,466
    Likes Received:
    16
    Device:
    iPhone 5S
    How so? It has the same Ram and Graphics as the 2nd Gen. Same processor. Multitasking works just fine on a 2nd Gen. Jailbreak multi-task works fine and Apple's multitasking supposedly uses up less resources so there shouldn't be a problem.

Share This Page