Question regarding Zenonia

Discussion in 'iTunes App Store Games & Apps' started by Artalos, May 13, 2009.

  1. Artalos

    Artalos New Member

    Joined:
    Feb 26, 2008
    Messages:
    16
    Likes Received:
    0
    Device:
    iPod touch
    Hi.

    Which firmware is required for it to run?
  2. Teslanaut

    Teslanaut Well-Known Member

    Joined:
    Sep 16, 2007
    Messages:
    15,588
    Likes Received:
    177
    Device:
    4G iPod touch
    The latest, obviously.
  3. Artalos

    Artalos New Member

    Joined:
    Feb 26, 2008
    Messages:
    16
    Likes Received:
    0
    Device:
    iPod touch
    Well, I was thinking, considering some of the new applications run on 2.2, right?
  4. matinsa2005

    matinsa2005 Banned

    Joined:
    Jan 22, 2008
    Messages:
    1,274
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    2.1 + .....
  5. DJ0ker

    DJ0ker New Member

    Joined:
    Apr 16, 2009
    Messages:
    157
    Likes Received:
    0
    Device:
    2G iPod touch
    BTW anyone know when it comes out !?
  6. Mat6393

    Mat6393 New Member

    Joined:
    Feb 28, 2009
    Messages:
    17
    Likes Received:
    0
    22nd ish
  7. elamre

    elamre Member

    Joined:
    Feb 2, 2009
    Messages:
    551
    Likes Received:
    11
    Device:
    4G iPod touch
    yep, only 2 days left!!

    Please Register or Log in to view images

    im so excitet! the first good rpg!

    Please Register or Log in to view images

Share This Page