Question on Windows 2000

Discussion in 'iPod touch' started by Zeustopher, Mar 22, 2009.

  1. Zeustopher

    Zeustopher New Member

    Joined:
    Mar 22, 2009
    Messages:
    5
    Likes Received:
    0
    Alright, I have a question that after researching I haven't been able to figure out an answer to.

    I'm wanting to buy an Ipod Touch and I want to for sure Jailbreak it. In order to do this I'll need Itunes- only problem is that as far as I can see itunes only supports up to version 7.3.3 for windows 2000.

    Please Register or Log in to view images



    My first question is does this version of itunes support the itouch? How can I find out? Does anyone have any suggestions on how I can get it to work? Any other input would be greatly appreciated.

    Please don't suggest upgrading to xp/vista. That is not an option. And yes- i know that Windows 200 sucks at pretty much everything. Its not my computer and I can't do anything about that.

    Please Register or Log in to view images



    Thanks for any help!

    -Zeustopher
  2. Duykur

    Duykur Banned

    Joined:
    Mar 24, 2008
    Messages:
    1,674
    Likes Received:
    0
    itunes 8 is required for an ipod touch 2g
  3. Zeustopher

    Zeustopher New Member

    Joined:
    Mar 22, 2009
    Messages:
    5
    Likes Received:
    0
    So I'd be pretty much out of luck then for Windows 2000? Does anyone else have any ideas?
  4. Finite Vendetta

    Finite Vendetta New Member

    Joined:
    Feb 4, 2009
    Messages:
    129
    Likes Received:
    0
    How is it you have an iPod Touch 2g before you have AT LEAST windows xp...before getting an expensive MP3 player invest in a newer os/computer -.-...fail...

    ANYWAY yeah you need iTunes 7.7+
  5. iamkewl

    iamkewl Banned

    Joined:
    Nov 9, 2008
    Messages:
    1,924
    Likes Received:
    0
    Your a dumbass, did you not read his post?

    He can't do anything about it because it's not his computer.
  6. blackwingcat

    blackwingcat New Member

    Joined:
    Mar 23, 2009
    Messages:
    1
    Likes Received:
    0
    iPod Touch Driver for Windows 2000

    Hi,
    I custmized iPod Touch XP Driver for Windows 2000.

    I released driver version 1.24 and 1.4

    My ipod touch works fine with iTunes 8.1 on Windows 2000.

    * You must use Windows 2000 XP API Wrapper Pack or KDW to run iTunes 7.7 or 8.x on Windows 2000
  7. shpock

    shpock New Member

    Joined:
    Jan 27, 2010
    Messages:
    13
    Likes Received:
    0
    Device:
    2G iPod touch
    @blackwingcat: your links are dead, could you upload it again if you ever gonna read this?

Share This Page