iOS 3.1 Question about tethered boot problems

Discussion in 'iOS Jailbreak & Cydia' started by Sparkyx, Apr 12, 2010.

  1. Sparkyx

    Sparkyx Member

    Joined:
    Aug 30, 2008
    Messages:
    225
    Likes Received:
    0
    Device:
    iPhone 4S (White)
    Hokay...so i have an iPhone 3Gs from a guy who claims it wasn't updated to 3.1.3. He had no problems booting it with blackra1n, until he reset the network settings on it one day, and the device failed to boot with blackra1n. It gets to the screen with GeoHot and doesn't reboot from there. I tried using Redsn0w to boot it and have even rejailbroken it with redsn0w too. Still no boot. I used iRecovery running the commands

    setenv auto-boot true
    saveenv
    fsboot

    ...I even tried it with the reboot command instead of fsboot. No luck.

    I'm not sure if the device was updated to 3.1.3 or not. It supposedly has the ECID SHSH on file on Cydia's server. I have edited my host file, but in DFU restoring to 3.1.2, I get the error saying the device is not eligible to be updated. Does that mean the ECID/SHSH isn't saved on the server? I'm not sure what's wrong with it. Here's a copy of my command prompt from iRecovery.

    C:\Documents and Settings\Adam\Desktop\iRecovery-MS-DOS>irecovery -s
    iRecovery - Recovery Utility
    by wEsTbAeR-- and Tom3q

    Got USB


    =======================================
    ::
    :: iBoot for n88ap, Copyright 2009, Apple Inc.
    ::
    :: BUILD_TAG: iBoot-636.66
    ::
    :: BUILD_STYLE: RELEASE
    ::
    :: USB_SERIAL_NUMBER: CPID:8920 CPRV:15 CPFM:03 SCEP:03 BDID:00 ECID:000002
    51DA0EF50F IBFL:01 SRNM:[880015373NS]
    ::
    =======================================

    [FTL:MSG] Apple NAND Driver (AND) RO
    [NAND] Found Chip ID 0x3295DE987A on FMI0:CE0
    [NAND] Found Chip ID 0x3295DE987A on FMI0:CE1
    [NAND] Found Chip ID 0x3295DE987A on FMI1:C8
    [NAND] Found Chip ID 0x3295DE987A on FMI1:CE9
    [FTL:MSG] FIL_Init [OK]
    [FTL:MSG] BUF_Init [OK]
    [FTL:MSG] FPart Init [OK]
    read new style signature 0x43313133 (line:375)
    [FTL:MSG] VSVFL Register [OK]
    [FTL:MSG] VFL Init [OK]
    [FTL:MSG] VFL_Open [OK]
    [FTL:MSG] YAFTL Register [OK]
    yaFTL::YAFTL_Open(l:2630): CXT is not valid . Performing full NAND R/O restore .
    ..
    [FTL:MSG] FTL_Open [OK]
    Boot Failure Count: 15 Panic Fail Cont: 0
    Delaying boot for 0 seconds. Hit enter to break into the command prompt...
    HFSInitPartition: 0x4fc3fcc0
    Kernelcache image not valid
    Entering recovery mode, starting command prompt
    limiting USB input current to 100 mA
    (Recovery) iPhone$ setenv auto-boot true
    (Recovery) iPhone$ saveenv
    (Recovery) iPhone$ fsboot
    (Recovery) iPhone$
  2. MrDodi

    MrDodi Active Member

    Joined:
    Feb 2, 2009
    Messages:
    1,519
    Likes Received:
    0
    Device:
    iPhone 5 (Black)
    try to boot with redsn0w, or use the Blackra1n fix, cause if youre at iTunes Version 9.1 , then blackra1n is broken.
  3. Sparkyx

    Sparkyx Member

    Joined:
    Aug 30, 2008
    Messages:
    225
    Likes Received:
    0
    Device:
    iPhone 4S (White)
    I already stated that i tried booting with Redsn0w. I am not using iTunes 9.1. I haven't upgraded yet.
  4. psyberdemon

    psyberdemon New Member

    Joined:
    Apr 13, 2010
    Messages:
    2
    Likes Received:
    0
    i have just experienced the same issue.

    MODEL: iPhone 3GS
    FIRMWARE: 3.1.2
    JAILBROKEN: YES.
    UNLOCKED: YES.
    SOFTWARE: blackra1n
    ITUNES: 9.0.3.15

    it has been jailbroken since day one with no problems until today.

    problems initially began when i was having problems with low ram availability -- 10 to 18mb of free ram when normally i have 100mb+. so, I shut down the iphone, ran geohot and successfully boot to springboard. ram problems were fixed, end of story, or so i thought.

    i started having problems seeing wifi at places in which i knew wifi was available -- a problem which i have seen and fixed before. so, i went to settings, general, reset, reset network settings, shut down the phone, ran geohot and cannot successfully boot.

    each time i turn on the phone i am presented with the recovery mode (as expected). i run blackra1n, geohot screen appears on the iphone, a minute passes, the phone restarts itself and goes straight back to the recovery mode... repeat, repeat, repeat. no success getting a boot to springboard.

    i am hoping somebody can provide a fix or a suggestion because there is information on my phone i would be heavily inconvenienced by losing to a restore... assuming that works.
  5. kingcoolryan

    kingcoolryan Member

    Joined:
    Oct 13, 2009
    Messages:
    627
    Likes Received:
    0
    Device:
    iPad w/ 3G
    Best bet would be dfu restoring to 3.1.3. Better to have a working iphone than a stuffed up 1
  6. psyberdemon

    psyberdemon New Member

    Joined:
    Apr 13, 2010
    Messages:
    2
    Likes Received:
    0
    unfortunately, it appears i am being forced in that direction. i am hesitant because i don't know which baseband version i have and it's pretty much impossible to tell from the state my phone is in.
    ------------------double post merged------------------
    The following is a link to iRecovery. It is supposed to be used to help get your 3GS out of recovery loop. I had forgotten about trying it before i started upgrading to 3.1.3. Oh well -- maybe it can help someone else. http://www.ihackintosh.com/2009/09/recover-iphone-3gs-from-apple-logo-or-recovery-mode-loop/
  7. kingcoolryan

    kingcoolryan Member

    Joined:
    Oct 13, 2009
    Messages:
    627
    Likes Received:
    0
    Device:
    iPad w/ 3G
    so you rely on baseband unlock? i suggest u make a thread about this. just try not to piggy back on this 1
  8. Sparkyx

    Sparkyx Member

    Joined:
    Aug 30, 2008
    Messages:
    225
    Likes Received:
    0
    Device:
    iPhone 4S (White)
    I ended up restoring it to 3.1.3...I'm having issues downgrading it now though...the SHSH signature is backed up too...BLahh
  9. LeSnak

    LeSnak New Member

    Joined:
    Jul 7, 2009
    Messages:
    185
    Likes Received:
    0
    Device:
    3G iPod touch
    just wondering can you restore a 3.1.2 iPhone 3GS to 3.1.2 again not update to 3.1.3 without any SHSH sigs backed eg.just restoring to the FW you are running again if you have any problems?

    thanks

Share This Page