Problems with locating music on my iPod Touch

Discussion in 'iTunes' started by TheKirk, Mar 5, 2009.

  1. TheKirk

    TheKirk New Member

    Joined:
    Feb 13, 2008
    Messages:
    1
    Likes Received:
    0
    Hi guys!

    I'm not sure if this is the right place, but here it goes..

    I've got a 1st generation iPod Touch 8GB, on which I've been running 1.2.2 firmware (jailbroken) for quite a long time.. Recently I bought the 2.2.0 update, and I have also jailbroken that, and it seems to work just fine.
    But of course I had to delete all my music before I could upgrade it, and now I wanna have it back on the iPod..
    In the beginning I used iTunes to sync my iPod, until I discovered that I could use winamp.. After a little while, I got Winamp to work with my iPod with no problems at all (And I find it MUCH better than iTunes...)
    I plugged in the newly updated ipod to Winamp, and it synced just fine.. I added my music, and it was done transferring after about 45 minutes.. According to winamp, the music was on my ipod, but it wasnt there.. well, at least not in Music.. On my iPod i went to settings/general/about, where it said that there were 0 tracks, but I could see on the space used that it was there.. I tried to enter my iPod from my computer via WinSCP, and all the tracks were there. They were located in /private/var/mobile/Media/iTunes_Control/Music and then in folders called F00 to F13, and they were all called 4 lettered names (Like ACZK.mp3, AKOF.mp3, RCWM.mp3 ect.).
    I've tried to delete them all and add them again, but nothing works. Sadly, it only works when I transfer via iTunes..

    What's the problem??

Share This Page