Problems: Upgrading from 2.1 to 2.2

Discussion in 'iPod touch Firmware 2.X' started by 3magin8, Dec 15, 2008.

  1. 3magin8

    3magin8 New Member

    Sep 10, 2008
    Likes Received:
    Today, I attempted to upgrade my 1st-Gen 16GB iPod Touch from 2.1 to 2.2 with iTunes.

    Everything was going smoothly until I noticed that the "verifying ipod software" message was being displayed for an excessive amount of time. I lost patience and closed unresponsive iTunes. I found my Touch in what I believe is recovery mode (guy with hands in the air with translated Russian saying, Preved = what's up).

    I tried to restore with iTunes but the same problem persisted with the "verfying" message.

    My touch is stuck with that restore picture and nothing seems to work.

    I've searched the net and some people are experiencing the same thing but I haven't found solutions.

    Please help!
    ------------------double post merged------------------
    I managed to restore my iPod.

    It seems that computer settings, configurations, or applications may affect the upgrading process.

    How I solved the problem, was restoring on another PC.

    More on it here:

    If anyone knows the exact problem, please provide info.

Share This Page