Problema con vt100, SSH, WinSCP y varias cosas más

Discussion in 'iFans en Español' started by mecanicista, May 20, 2008.

  1. mecanicista

    mecanicista New Member

    Joined:
    Apr 8, 2008
    Messages:
    11
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    Salud. Tengo un iPod Touch 32GB 1.1.4. El primer día, gracias a la información que encontré en este foro, pude hacerle el Jailbreak con ZiPhone, instalar aplicaciones, personalizarlo &c. Siempre sin problemas -incluyendo iSlsk-, hasta ayer.

    Me encontré el primer problema jugando con la Terminal vt100. Funcionaba perfectamente hasta que empezó a salirme este mensaje:

    dyld: Library not loaded: libarmfp.dylib
    Reference from: /bin/sh
    Reason: image not found
    [Process completed]


    y el cursor inmóvil al final del mensaje. No funciona el teclado, no responden los controles que aparecen pulsando la pantalla y tengo que salir manteniendo el botón home.

    Intenté conectarme con el WinSCP, que hasta entonces había funcionado bien, para buscar esa librería, y me encontré con que aparece otro mensaje de error:

    El servidor cerró inesperadamente la conexión

    Desde entonces, no fui capaz de conectarme vía SSH. También me fallaba el Squid. La red wifi no ha fallado.

    He probado casi todo lo que se me ha ocurrido: desinstalar y reinstalar varias cosas (la Terminal, Jiggy Runtime, OpenSSH, el Installer, &c.), intenté entrar desde WinSCP sin contraseña, y también intenté reinstalar BSD Subsystem, y nunca lo permite: Package download failed.

    Esta mañana hice un force restore, reinicié el iPod a 1.1.4 con el iTunes, copié mi música (tenía un backup) y volví a hacer un jailbreak con ZiPhone, igual que había hecho en su día. Todo correcto, en apariencia, comencé a reinstalar las aplicaciones y sigo igual que ayer: sin SSH, sin que funcione la vt100. Bueno: peor que ayer, pues varios diccionarios inglés-español que tenía, algunos .doc y otras cosas que había copiado vía WinSCP los he perdido, claro.

    Otro problema, que no sé si tiene algo que ver, me sucede cuando intento instalar SUID Lib Fix. Ya sabéis: Main script execution failed!, que por lo que he visto en los foros españoles e ingleses es un clásico.

    En su momento, además, moví Fonts y Ringtones a la partición grande con BossTool. Ahora me encuentro con que no me permite mover las fuentes, sólo los ringtones, así que tengo 21mb libres, frente a los 92mb que tenía ayer, y eso con muchas menos aplicaciones instaladas.

    Repito: la red wifi funciona bien. Puedo instalar cosas y actualizar. Pero no acceder a los archivos con SSH, cambiar permisos ni, claro, copiar archivos hacia o desde el iPod.

    Si alguien sabe solucionar este problema se lo agradezco.
  2. mecanicista

    mecanicista New Member

    Joined:
    Apr 8, 2008
    Messages:
    11
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    Solución temporal

    Un segundo restore me ha permitido solucionar el acceso por SSH. Como creo que el orden en el que he hecho las cosas puede ser importante, lo copio aquí.

    1. Force restore.

    2. Restauración. Conexión con ITunes. Le digo que lo trate como si fuera un iPod nuevo, y no que utilice el backup de mis preferencias que ya tenía guardado.

    3. Instalar software 1.1.4.

    4. Jailbreak con ZiPhone.

    El jailbreak instala en el iPod:
    -Installer 3.11
    -BSD Subsystem 2.1
    -OpenSSH 4.6p1-2

    5. Ejecutar Installer, actualizar (3.11) y reiniciar.

    6. Probar WiFi. Tenía habilitada una contraseña; se la he quitado, por si acaso.

    7. Probar WinSCP:

    7.1. IP del iPod
    7.2. User: root - Password: alpine
    7.3. desde WinSCP Ctrl-T, y ejecutar

    chmod 4755 /Applications/Installer.app/Installer
    chmod +s /Applications/Installer.app/Installer

    Con esos dos comandos ejecutados ya puedo

    8. Instalar SUID Lib Fix 1.0

    9. BossPrefs

    10. BossTool. Ejecutar:

    10.1. Relocate Fonts
    10.2. Relocate Ringtones

    Y listo.

    He dejado para hoy la instalación y prueba de la terminal vt100, SysInfo, iSlsk, la caja de ritmos IR-909 y una tabla periódica de elementos. Las dos primeras aplicaciones me funcionaron bien varios días, así como iSlsk. la IR-909 y la tabla periódica fueron lo último que había probado antes del desastre, así que puede que espere nuevas versiones.

    Espero que esto le sirva de algo a alguien más.
  3. guarroman

    guarroman New Member

    Joined:
    May 21, 2008
    Messages:
    5
    Likes Received:
    0
    Que hay!
    No estás solo en todo esto... acababa de leer tu primer post, me he dado de alta y veo que te contestas a tí mismo.

    Te cuento mi caso: 1.1.4 8Gb JB con ZIphone funcionando perfecto varios meses con cuetro paginas de apps instaladas sin problemas, yo moví todas mis apps a la otra partición usando un enlace simbólico, lo he hecho cuatro veces y va muy bien

    Pero bueno todo eso da igual, lo que importa es que mis síntomas son los mismo que los tuyos, desde ayer experimento problemas como tú

    El ssh lo inicias y se muere, lo desinstalas, lo instalas y te da el erro que comentas con el winscp
    El vt100 me da exactamente el mismo error que a tí

    Y hay dos cosa que pienso que pueden ser las causantes:

    -El installer 3.11
    -El iSlsk

    Los dos me los instalé ayer, bueno el installer no se me instaló, algo pasó y desde entonces tengo el error de package download failed, claro, intenté conectarme por winscp y empecé a experimentar los problemas

    El caso es que estamos con las manos atadas pues si no podemos hacer winscp y no podemos acceder a la vt100 a ver como modificamos ficheros o permisos

    Hay que averiguar quién fue el causante del porblema, si una instalación fallida del installer 3.11 (te pasó esto a tí) o el iSlsk

    Estoy a punto de restaurar del todo. Esperaré a mañana quizá

    pero molaría detectar el fallo, seguro que somos muchos los afectados
  4. guarroman

    guarroman New Member

    Joined:
    May 21, 2008
    Messages:
    5
    Likes Received:
    0
    Por cierto instalaste el 3.1 Installer fix de iClarified????
    porque se me ha olvidado comentar que yo lo hice, como pensaba que era un problema del installer, he leido por ahí que no lo instalemos....
  5. guarroman

    guarroman New Member

    Joined:
    May 21, 2008
    Messages:
    5
    Likes Received:
    0
    Aplicacione que no van con los síntomas comentados

    - Lights off (I have installed this and doesn't work for me also)
    - Five dice
    - Super pong
    -SSH
    - iPac3d
    - Yeti3d
    - Shoplist
    - vNotes
    - Pocketmoney
    - Geopedia
    - Vt-100 (error commented above)

    ¿Qué tienen en común todas estas aplicaciones?
  6. guarroman

    guarroman New Member

    Joined:
    May 21, 2008
    Messages:
    5
    Likes Received:
    0
    bueno algo más he conseguido

    http://hackint0sh.org/forum/showthread.php?t=40327&page=12

    Aquí hablan de como hacer algo

    y es esto:


    1) Install PureFTPD
    2) Install BossPrefs
    3) Install BossPrefs PureFTP Control
    4) Set auto-lock to NEVER
    5) Open BossPrefs, enable wifi, enable PureFTP
    6) STAY IN THIS SCREEN!!!
    7) Open FTP application (FlashFXP for instance), login with iPhone ip adress (user=root, pass=alpine)
    8) Rename or remove /usr/lib/libarmfp.dylib
    9) Copy old libarmfp.dylib to /usr/lib

    hasta el punto 8 todo claro, pero cuando me meto fon el ftp veo que lo que hay son enlaces simbólicos a librerias que no encuentro por ningun lado entre ellas la famosa libarmfp.dylib

    lo que he hecho yo a partir del punto 7 es
    8) renombrar el enlace simbólico /usr/lib/libarmfp.dylib y meter en esa carpeta la libreria libarmfp.dylib que he encontradoaquí


    entonces ahora me va el VT-100 y el SSH y las aplicaciones que no iban también

    pero aún no he podido con el installer 3.11 ni con la reinstalación del BSD subsystem
  7. guarroman

    guarroman New Member

    Joined:
    May 21, 2008
    Messages:
    5
    Likes Received:
    0
    bueno me he conectado por SSH

    y he hecho todo esto:
    rm -R /var/mobile/Library/Caches/Installer
    rm -R /var/mobile/Library/Installer/Temp
    chmod -R 755 Installer.app
    chown -R root:admin Installer.app
    chmod 6755 /Applications/Installer.app/Installer


    Y ya he podido actualizar el installer a la 3.11

    pero sigo mosca porque he copiado la librearía libarmfp.dylib a pelo en /usr/lib y me he cargado el enlace simbólico y no me mola nada

    Sugerencias?
  8. mecanicista

    mecanicista New Member

    Joined:
    Apr 8, 2008
    Messages:
    11
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    Salud. Ahora tengo el iSlsk funcionando. Y bien. Me bajé cuatro canciones, las exporté, les modifiqué las tags desde el iTunes. Todo perfecto. (Bueno, excepto que no tengo manera de copiar esas canciones en mi disco duro, para añadirlas a la copia de seguridad de la biblioteca musical... Supongo que no estaba previsto mover canciones del iPod al PC o Mac, siempre y cuando se suponía que todas las canciones del iPod habían salido previamente de otra máquina local, je, je.)

    Sigo sin atreverme con la Terminal. Por lo que he leído por ahí, parece importante tener instalado el SUID Lib Fix, cosa que ahora sí he hecho y antes no podía (he visto varias frases como esta: "Try installing the SUID lib fix. Believe me, it works... at least for older errors."). También encuentro que las versiones soft 1.1.3. tienen un problema con la contraseña al entrar en la Terminal. A mí no me pidió contraseña en la puta vida, así que debe ser algo solucionado por la 1.1.4.

    Mi problema es que no tengo ni idea de nada. Soy MUY BUENO siguiendo instrucciones que leo por ahí, le echo valor y hago lo que sea. Y luego suelo recordar bien todo lo que he hecho, paso a paso. Pero, en realidad, no sé lo que hago. Soy un usuario avanzado y un informático en pañales.

    No veo ningún Installer fix en mi iPod. ¿? Y el Installer que tengo es el 3.11, sin que tuviera que hacer nada antes.

    O.T. Tu comentario sobre PureFTP ha sido un éxito, y ya está incluso traducido al inglés. Enhorabuena.
  9. mecanicista

    mecanicista New Member

    Joined:
    Apr 8, 2008
    Messages:
    11
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    Parece que el problema pudo ser el Installer Fix de iClarified:

    Do not install “3.1 installer fix”. This package may cause your terminal, ssh, and bsd subsystem to be unusable based upon how you have installed BSD subsystem in the past. I have talked with the folks over at iClarified, and the package is being removed for further testing.

    de http://sleepers.net/news/?p=132

    Voy a probar la vt100.

    Hecho. De momento, f unciona. Y WinSCP, también.

    Espero que todo esto le sirva a alguien, porque parezco un imbécil, hablando solo.
  10. lachinaenelzapato

    lachinaenelzapato New Member

    Joined:
    May 31, 2008
    Messages:
    1
    Likes Received:
    0
    gracias por todo aunque no lo creas lo que haces sirbe y creeme mucho aunque parezca que predicas en el desierto perdonad mi pobre ortografia lo mio es con un touch que me tiene frito pero voy tirando ya te cuento en otro momento

Share This Page