iOS 3.1 Problem with Ipod touch (MC model) late 2G fw 3.1.2

Discussion in 'iOS Jailbreak & Cydia' started by jaman007, Apr 4, 2010.

  1. jaman007

    jaman007 New Member

    Joined:
    Apr 4, 2010
    Messages:
    1
    Likes Received:
    0
    Device:
    iPod touch
    Hi!
    I have a problem. I bought Ipod touch (8GB) from a friend which he bought 2 months ago. He didn't jailbrake it, but he upgraded to 3.1.3 fw. When I got it, I downgrade it to 3.1.2 for easy jailbreak. But then I've had major problems. When I tried to jailbreake it with blackra1n method it stucked with rebooting, it just went to restore mode and it stucked, the application got error and I couldn't finished the jailbreak (i tried on 2 computers). Then I tried redsn0w 0.9.2 method I first installed Cydia and it was fine, but when I clicked Tethered method it went on restore mode and it wasn't working again. So what is the problem? My ipod is MC model. What should I try? Tnx for the answers.

    P.S.
    When I downgrade it, I installed firmware for 2G model, cuz for 3g didnt restore it, so that means its 2G?

Share This Page