Problem trying to get around 3rd Party Limit in 1.1.2

Discussion in 'iPod touch 1.1.x Jailbreak' started by eozoon, Nov 28, 2007.

  1. eozoon

    eozoon New Member

    Oct 5, 2007
    Likes Received:
    2G iPod touch

    I've finally tried to upgrade to 1.1.2. All seems to work fine and it rebooted with Installer and SSH installed.
    However, when I tried to remove the 3rd Party limit, I got the "mv: /bin/: terminated with 1 (non-zero) status: Cross-device link" error.

    So I followed the instruction here and used a slightly different set of codes instead, but now I'm getting a "ls: not found" message when I enter ls -la to check that the link is set up correctly.

    I don't dare to reboot without making sure the link was set up. Is there anyway other way to check?

    Last login: Thu Nov 22 18:31:24 2007 from
    # mv /Applications /private/var/Applications
    mv: /bin/: Permission denied
    mv: /bin/: terminated with 1 (non-zero) status: Cross-device link
    # ^C
    # cp -R /Applications /private/var/Applications
    # rm -rf /Applications
    # ln -s /private/var/Applications Applications
    # ls -la
    ls: not found
    I ran out of patience and tried to reboot, and winded up with a blank home screen.
    Luckily SSH still worked, so I moved all the apps back by "cp -R /private/var/Applications /Applications"
    I tried setting up the sym link again, and is still getting the same error.
    Help please? Right now everything works (no restore needed, and I've access to existing apps), but I'd like to have more room for installing more apps in the future..
    not sure if this is relevant, when running "windows.bat" for the jailbreak, the screen got stuck at "Rebooting device...", I waited 30 minutes and killed that screen. Things seems to work despite that. (got Installer and SSH on the screen).
    I saw in another thread that someone suggested a few command that was supposed to fix the "mv: /bin/: Permission denied" problem. I ran the first line of it and got the following error:

    # /bin/chmod 555 /bin/ls
    chmod: /bin/ls: No such file or directory

Share This Page