iOS 4.0 Possible Way to Jailbreak 4.0 Betas (using spirit)

Discussion in 'iOS Jailbreak & Cydia' started by ownerofspam, May 22, 2010.

  1. ownerofspam

    ownerofspam Banned

    Joined:
    Nov 1, 2008
    Messages:
    311
    Likes Received:
    0
    Device:
    3G iPod touch
    Comex recently released the code for Spirit to run on Linux, and in doing so released bits and pieces of the source code.

    http://github.com/posixninja/spirit-linux/blob/master/igor/map.plist

    Posted here is the codes that it uses to jailbreak the device using the dylib from the firmware. Basically, this is what checks if you're on 3.1.3 or 3.1.2 and allows spirit to jailbreak your device.

    Technically, if we were to add this line in, we could jailbreak any 4.0 beta.

    (This is an example for an iPod Touch 3g)

    <key>iPod3,1_4.0</key>
    <string>igor/f6c17e934ba0ad477812de0b7cb019396d259d93.dylib</string>

    (I think this might be the correct dylib for 4.0 for iPod Touch 3g, but I'm not entirely sure)


    So, if we can find out the filecode for the dylib (I would do it right now, but not being near my Mac at work to go on 4.0 beta, and not being near linux to run this) we could jailbreak 4.0 betas.


    Please keep discussion relevant.
  2. freemini

    freemini Active Member

    Joined:
    Sep 11, 2008
    Messages:
    1,656
    Likes Received:
    2
    Device:
    iPhone 5 (Black)
    Well, good luck with that. But I highly doubt it's gonna work..
  3. ownerofspam

    ownerofspam Banned

    Joined:
    Nov 1, 2008
    Messages:
    311
    Likes Received:
    0
    Device:
    3G iPod touch
    Why is that? By adding this string you verify to Spirit that it is allowed to jailbreak 4.0 running on a iPod touch 3G. There really is no reason why it wouldn't work.
  4. jmwerkus

    jmwerkus Active Member

    Joined:
    Apr 9, 2009
    Messages:
    3,030
    Likes Received:
    17
    Device:
    iPhone 5S
    I already did this, the day spirit came out, it doesnt work.
  5. ownerofspam

    ownerofspam Banned

    Joined:
    Nov 1, 2008
    Messages:
    311
    Likes Received:
    0
    Device:
    3G iPod touch
    Did it give you a 4.0 not supported error or could you click jailbreak and it wouldn't do anything?
  6. jmwerkus

    jmwerkus Active Member

    Joined:
    Apr 9, 2009
    Messages:
    3,030
    Likes Received:
    17
    Device:
    iPhone 5S
    it said 4.0 not supported, i edited the map.plist thing to get it to support 4.0, and then it allowed me to hit jailbreak. When i hit it, i went into an infinite loop.
  7. ownerofspam

    ownerofspam Banned

    Joined:
    Nov 1, 2008
    Messages:
    311
    Likes Received:
    0
    Device:
    3G iPod touch
    What dylib did you set it to use?
  8. jmwerkus

    jmwerkus Active Member

    Joined:
    Apr 9, 2009
    Messages:
    3,030
    Likes Received:
    17
    Device:
    iPhone 5S
    <key>iPhone2,1_3.1.3</key>
    <string>igor/b735701843456754988021d128c2671ee36d1b04.dylib</string>

    as i have a 3GS, i used this one, for 3GS
  9. personman

    personman Active Member

    Joined:
    May 1, 2008
    Messages:
    1,466
    Likes Received:
    16
    Device:
    iPhone 5S
    And did it work?
  10. jmwerkus

    jmwerkus Active Member

    Joined:
    Apr 9, 2009
    Messages:
    3,030
    Likes Received:
    17
    Device:
    iPhone 5S

Share This Page