Podcasts not syncing right

Discussion in 'iPod touch' started by ahrenba, Feb 20, 2008.

  1. ahrenba

    ahrenba New Member

    Joined:
    Feb 9, 2008
    Messages:
    92
    Likes Received:
    1
    Hey Guys,

    I have a jailbroken 1.1.3 iPod touch (16GB).

    Here are my podcast settings:
    Edit -> Preferences -> Podcasts:
    Check for new episodes - Manually
    When new episodes are available - Download the most recent one
    Keep - Last 3 episodes

    Devices -> iPod -> Podcasts:
    Checked next to Sync - 3 most recent episodes of:
    All Podcasts

    On my old iPod 5G, it would transfer the podcasts, and then obviously when I watched/listened to them on the device (iPod), next time I synced with iTunes, it would pick that up and un-mark the given episodes as new and would also place a bookmark where I left off.

    Question:
    However, with my new iPod touch, it syncs and deletes the episodes fine, but iTunes does not recognize that the episode has been played on the device and never marks it as "not new". Therefore, every time I sync, it tells the iPod that all episodes are new and erases the bookmark since it didn't detect they have been played and remarks it as "new".

    Is there a way to fix this?
  2. kingslaye505

    kingslaye505 New Member

    Joined:
    Jan 2, 2008
    Messages:
    57
    Likes Received:
    0
    Which method did you use to jailbreak? Certain methods (like the natetrue method) have different glitches in them. The best thing to do would probably be to downgrade and rejailbreak with ijailbreak or Devteam. First, I would back up your applications and application data so that you can put it back on later.
  3. ahrenba

    ahrenba New Member

    Joined:
    Feb 9, 2008
    Messages:
    92
    Likes Received:
    1
    I used iPodTouchMaster's method. What is the best way to back applications, and data?
  4. kingslaye505

    kingslaye505 New Member

    Joined:
    Jan 2, 2008
    Messages:
    57
    Likes Received:
    0
    Do you know how to use SSH for this? I can tell you how to do it for PC if you don't.

    -Install OpenSSH in Installer. It should be under system.
    -Find the IP Address of your iPod. Go to Setting -> Wi-Fi -> The arrow next to the network you are on -> IP Address
    -Install WinSCP (http://winscp.net/eng/index.php)
    -Create an account with the host as your IP Address, the username root, and the password alpine
    -Login to your iPod. You should see a folder called library. Take note of the folder you are in (the name escapes me right now sorry) and copy the library folder somewhere on your computer making sure that you know where it came from.
    -Go up one level of folders and you should see many. Enter the one called mobile. You should see the same setup as before. Again, backup your library folder, taking note that it is from the mobile folder.
    -Go up to the highest level of folders and backup the folder called applications.
    -When you have rejailbroken your iPod, you can put all these folders back and your iPod will be just like it was before.

    Did this problem start occuring when you installed new software as well? It sounds like it could be a conflict with a program, howver I think it might be a jailbreaking glitch.
  5. ahrenba

    ahrenba New Member

    Joined:
    Feb 9, 2008
    Messages:
    92
    Likes Received:
    1
    Thanks for the response. Yes, I have used SSH before with my iPod so I know how to use it. However, your guide will probably help others who come to this thread, so thanks for posting that.

    You know, I never really tested the podcast syncing with a non-jailbroken iPod touch. Right when I got it, I jailbroke it and brought it up to 1.1.3. Hmmm...this is quite frustrating. There seems to be no solution other than manually marked the episodes as "not new" every time!

    Please Register or Log in to view images

    Please Register or Log in to view images

  6. ahrenba

    ahrenba New Member

    Joined:
    Feb 9, 2008
    Messages:
    92
    Likes Received:
    1
    Has anyone found a solution yet? Thanks.

Share This Page