Please Help - iPod 3.0 Jailbroke won't turn on!

Discussion in 'iPod touch' started by Crysis SK9, Oct 15, 2009.

  1. Crysis SK9

    Crysis SK9 New Member

    Joined:
    Jan 18, 2008
    Messages:
    15
    Likes Received:
    0
    Device:
    2G iPod touch
    I just upgraded my iPod Touch 2G to firmware 3.1.2 from 2. something.
    First thing I do, of course, is Jailbreak it. Everything went fine and it was all good. But for some reason I couldn't get the themes to work, and iPhone Browser wasn't recognizing my Jailbroken iPod. So I tried respringing, didn't work. So I turned the power off. When I tried to turn the power back on, the Apple logo shows up, but after ~10 seconds it goes black. Doesn't turn on at all. I figured it was out of batteries, but when I plug it in my computer doesn't recognize it. I've tried to restore it by holding down the Home and Sleep button but it didn't work. DFU didn't work either. Since my 1G broke and I bought this 2G over the summer it should still be under warranty. But with it Jailbroken and all I don't want to have to take it into the Apple Store.
    Anything I can do? Thanks in advance.
  2. Frostbite714

    Frostbite714 Active Member

    Joined:
    Aug 18, 2008
    Messages:
    228
    Likes Received:
    46
    Device:
    iPhone 5S
    my 1g wouldnt turn on one day. All i did was hold the home button and power putton down for 10 seconds and that turned it on. If that doesnt work i dont know what else to tell you, except dont give up. theres always a way to fix your ipod touch...unless you ran it over with a car. If no one else can give you a helpful response, search this site for someone else with your problem.

Share This Page