"Package Download Failed!"

Discussion in 'iOS Jailbreak & Cydia' started by steeped, Feb 2, 2008.

  1. steeped

    steeped New Member

    Joined:
    Sep 24, 2007
    Messages:
    718
    Likes Received:
    9
    I am getting this error for every program I am trying to install in the installer.

    What's wrong?
  2. spazzywulf

    spazzywulf New Member

    Joined:
    Feb 1, 2008
    Messages:
    8
    Likes Received:
    0
    no clue

    this keeps happening to me too. I have no idea why its happening though
  3. upd

    upd New Member

    Joined:
    Dec 25, 2007
    Messages:
    171
    Likes Received:
    1
    Device:
    iPhone 3GS (White)
    I think that something in the sources was changed (location of files, maybe?). Just go into Sources and tell them to refresh. I was having the same problem also, but after debugging many things (router, Wifi, other programs in installer, rebooting iPod) I finally just refreshed the sources and everything works again!
  4. spazzywulf

    spazzywulf New Member

    Joined:
    Feb 1, 2008
    Messages:
    8
    Likes Received:
    0
    I've refreshed multiple times multiple times and have tried rebooting the iPod. it's still not working.
  5. excursion

    excursion Member

    Joined:
    Nov 12, 2007
    Messages:
    87
    Likes Received:
    0
    Device:
    iPod touch
    If you upgraded your installer, then thats your problem. It can also be the files inside the Library/Installer/ directory.
  6. spazzywulf

    spazzywulf New Member

    Joined:
    Feb 1, 2008
    Messages:
    8
    Likes Received:
    0
    Is there anything I can do to fix this then?
  7. dietztho000

    dietztho000 Member

    Joined:
    Jan 26, 2008
    Messages:
    566
    Likes Received:
    17
    Device:
    3G iPod touch
    same problem here, in fact its all over the threads but no one seems to have a clear solution
  8. Mindfield

    Mindfield New Member

    Joined:
    Nov 5, 2007
    Messages:
    1,312
    Likes Received:
    7
    I'm having the same problem with a bunch of apps. They seem to transfer okay, but as soon as the transfer is done it throws that error.

    I think it might have something to do either with Installer's XML parsing, or the source's are using malformed XML that earlier versions of XML were more forgiving with, perhaps. Either way I hope it gets sorted soon because there are a few important apps that I just can't download as a result. (I want my Categories!)
  9. excursion

    excursion Member

    Joined:
    Nov 12, 2007
    Messages:
    87
    Likes Received:
    0
    Device:
    iPod touch
    Well if you DID upgrade and it DOESN'T work, then replace your installer app with the one attached. Set permissions to 755 and it should work. I uploaded it on another thread and it worked for the guy with the same problem.

    Attached Files:

  10. excursion

    excursion Member

    Joined:
    Nov 12, 2007
    Messages:
    87
    Likes Received:
    0
    Device:
    iPod touch
    Mindfield, if you want I can upload my Categories.app for you.

Share This Page