Osx86 help...iokitwaitquiet() times out

Discussion in 'Mac & OS X' started by Parm289, Jun 1, 2008.

  1. Parm289

    Parm289 New Member

    Joined:
    Jan 21, 2008
    Messages:
    348
    Likes Received:
    6
    Device:
    iPod touch
    ...I tried updating my 10.5.1 Leo install using the apple combo update procedure, where you delete the kexts after install. Well, my install went to 18% and I got a kernel panic. I didn't want to update, but my Internet kept dropping every 2 minutes so I figured I'd give it a try.

    So now I've reinstalled Leo from iatkos 1.0ir3. I was getting so many kernel panics that I decided to replace the current extensions folder with my backup. I deleted the new extensions folder and copied my old one to the install. Now, I don't think I get kernel panics (I have been booting with -v), but the boot just sits at:

    kextd [#]: iokitwaitquiet() timed out while trying to write kernel symbols

    And then after that I get another line saying interfacenamer timed out waiting for iokitwaitquiet to quiesce. I've searched for three hours on every site I could find, and can't find any solutions. It's driving me absolutely insane.

    So can anyone here tell me what's wrong, or at least point me to a helpful thread somewhere? Thanks.
  2. drkassassin

    drkassassin New Member

    Joined:
    Dec 14, 2007
    Messages:
    1,251
    Likes Received:
    26
    Device:
    2G iPod touch
  3. Parm289

    Parm289 New Member

    Joined:
    Jan 21, 2008
    Messages:
    348
    Likes Received:
    6
    Device:
    iPod touch
    Thanks for the link, but I already looked at it and that solution won't work for me. My bios only has 2 setting for sata and IDE: on and disabled.

    This error is why I havent responded to your pm yet...I need to get this working.

    It looks like nobody has solved this problem...
  4. drkassassin

    drkassassin New Member

    Joined:
    Dec 14, 2007
    Messages:
    1,251
    Likes Received:
    26
    Device:
    2G iPod touch
    so this happens even if you dont do the the combo update? am i correct? or is it only when you do the update?
  5. Parm289

    Parm289 New Member

    Joined:
    Jan 21, 2008
    Messages:
    348
    Likes Received:
    6
    Device:
    iPod touch
    No - what happened was:

    1. I had a working 10.5.1 install
    2. My network kept dropping every 5 minutes, and only a restart fixed it, so I decided to update to 10.5.3, which was supposeed to fix the problem.
    3. During the update, I got a kernel panic.
    4. I needed to reinstall, which I did.
    5. I replaced the kernel with my custom one, and replaced the new extensions folder with my old backup.
    6. I now have this problem.

    It really sucks...I'm pissed that I did such a stupid thing.
  6. Teslanaut

    Teslanaut Well-Known Member

    Joined:
    Sep 16, 2007
    Messages:
    15,588
    Likes Received:
    177
    Device:
    4G iPod touch
    Wait, which update did you download/use? Because if you got the ones from Apple, there are 2 different ones. One for Going from 10.5.2 -> 10.5.3 And one for going from 10.5/10.5.1 --> 10.5.3. That may have caused the problem.
  7. Parm289

    Parm289 New Member

    Joined:
    Jan 21, 2008
    Messages:
    348
    Likes Received:
    6
    Device:
    iPod touch
    I got the combo update, and followed the instructions that you posted here. There was just a kernel panic at 18%.

    But now I'm on a reinstall, and I havent booted into osx yet. This error is driving me insane.

    I played with the bios, extensions, kernel, everything. I'm thinking I might just do another reinstall.

    Edit: Is it safe to replace the whole extensions folder with my backup? Or should I only replace the custom and edited kexts?

Share This Page