OS 3.1.3 Update Kills Tethered Jailbreaks

Discussion in 'Front page news archive' started by News Bot, Feb 3, 2010.

  1. News Bot

    News Bot iFans.com News

    Joined:
    Sep 14, 2007
    Messages:
    7,367
    Likes Received:
    285
  2. kixphlat

    kixphlat Member

    Joined:
    Nov 30, 2007
    Messages:
    643
    Likes Received:
    1
    Device:
    iPhone 4S (Black)
    thanks for the quick update!
  3. doriangh

    doriangh Active Member

    Joined:
    Oct 7, 2009
    Messages:
    859
    Likes Received:
    113
    Device:
    iPhone 6
    I tried this with the redsn0w 0.9 and it couldn't find the .ipsw file!! do I need to upgrade first? Do I only need the .ipsw file? hellllp!!
  4. studangerous

    studangerous Super Moderator Emeritus Staff Member

    Joined:
    Dec 2, 2007
    Messages:
    5,975
    Likes Received:
    30
    Device:
    iPhone 4 (Black)
    There seems to be a number of 3GS users unaware about key signing and the need to back up current firmware keys in order to allow them to downgrade back to their current firmware in future. So here's a bit more info:

    • When you install a firmware on the iPhone 3GS it contacts Apple's servers to check your device is on the latest firmware and if so it will activate it. Older firmwares are not supported by Apple and so will not be activated.

    • You can get around this by going into Cydia or Rock and have your devices ECID SHSH signatures stored on Saurik's or Rock's servers. This will allow your current firmware to continue functioning when Apple stop supporting it. It will also allow you to downgrade back to this firmware version and activate it by spoofing it to Cydia's or Rock's servers instead of Apple's.

    • On the Cydia main screen if it says 'This device has SHSHs on file for iPhone OS: 3.1.2' then you are backed up. If not hit the prompt to back them up. I would presume it's a very similar in Rock.

    Need more info still? Check Saurik's blog post 'bypassing the overlord' and iGuru's Understanding The iTunes Verification Server [PDF]
  5. tech3475

    tech3475 Active Member

    Joined:
    Sep 23, 2008
    Messages:
    974
    Likes Received:
    30
    Device:
    iPhone 4 (Black)
    When they say older ipod touch 2g, do they really mean the 3G? Or are they still selling the 8GB model with the new bootrom?

    I wonder what Apple plan to do with the 4G to stop freedom, i mean jailbreaking.
  6. Soutar_3DG

    Soutar_3DG Member

    Joined:
    Mar 29, 2009
    Messages:
    296
    Likes Received:
    0
    Device:
    2G iPod touch
    no when they say older ipod touch 2g they mean the touch from 2008 the proper 2g, not the recently updated ones that came out in september
  7. killerz3r0

    killerz3r0 Member

    Joined:
    Sep 3, 2008
    Messages:
    63
    Likes Received:
    3
    I can see anything about ECID in Cydia, nothing about previous backups nor the "Make my Life Easier button!"

    When I used rock I clicked "Save 3GS SHSH for 3.1.2 Restore (Saurik)" and it loads a page with nothing on it (just the regular background with blue and light blue lines). Is this normal? Please advice what to do! I don't want to be unable to restore.
  8. nicknowsky

    nicknowsky New Member

    Joined:
    Mar 3, 2009
    Messages:
    86
    Likes Received:
    0
    Device:
    iPad
    NOPE!! goto settings>general>about> SCROLL down till you MODEL, if you have ipod touch 2g with a MODEL that starts with MC you are SCREWED for the time being, Luckily I haven a MB MODEL (yes!!!) gonna ttry out the Redsn0w loophole right now]

    It doesnt have to be from 2008, i got mine in 2009 and its the best model of ipod touch 2g, u just have to have bought one before last summer
  9. killerz3r0

    killerz3r0 Member

    Joined:
    Sep 3, 2008
    Messages:
    63
    Likes Received:
    3
    I have 3GS MC model what does that mean?
  10. studangerous

    studangerous Super Moderator Emeritus Staff Member

    Joined:
    Dec 2, 2007
    Messages:
    5,975
    Likes Received:
    30
    Device:
    iPhone 4 (Black)
    It means you have the 3GS with the new bootrom and so you definitely shouldn'T be upgrading to 3.1.3 if you want to jailbreak.

    The old bootrom was exploited so devices using it are 'pwned-for-life'. To date the new bootrom hasn't been hacked so the jailbreak is at a higher level which Apple can close with updated OSes.

Share This Page