OpenSSH and BSD subsystem?

Discussion in 'iPod touch' started by m26k9, Nov 7, 2007.

  1. m26k9

    m26k9 New Member

    Joined:
    Oct 30, 2007
    Messages:
    99
    Likes Received:
    0
    Hi guys...

    I have a problem with SSH'ing in to my iPot... I jailbroke succesfully with slovix.com/jb and it automatically installed and when I try to SSH I get a "Network unreachable" error...
    then I tried to install the OpenSSH from installer.. but it complained that it needs BSD subsystems.. I want to know if I should install it or whether the already installed SSH cliet should work... BSD subsystem is 6+MB so I'm a bit reluctant to install it... what do you guys think..?
  2. everpress

    everpress New Member

    Joined:
    Oct 29, 2007
    Messages:
    18
    Likes Received:
    0
    As far as I know, the BSDSub is a needed component to run OpenSSH.
    So it takes up 6+ mB... It allows you to SFTP onto your touch.

    You already jailbreak'd... Might as well get the full functionality out of it.

    Please Register or Log in to view images

  3. m26k9

    m26k9 New Member

    Joined:
    Oct 30, 2007
    Messages:
    99
    Likes Received:
    0
    I'm just worried if installing another SSH app would mess with system... I guess I should give it a go.. thanks man...
  4. Fatfrank

    Fatfrank New Member

    Joined:
    Oct 25, 2007
    Messages:
    169
    Likes Received:
    0
    Device:
    2G iPod touch
    It shouldn't, I installed above programs and everything is working fine
  5. romeboards

    romeboards Active Member

    Joined:
    Oct 2, 2007
    Messages:
    1,297
    Likes Received:
    17
    Device:
    iPhone 3G (Black)
    you can have as many ssh's as you want i think. I have two, one from touchfree and from open ssh, and they work fine together. I just never took one of them off because i live by the golden rule- 'if it aint broke dont fix it.'

Share This Page