OMG Why does Apple have to make it so confusing?????????

Discussion in 'iPod touch' started by keepup, Aug 15, 2008.

  1. keepup

    keepup New Member

    Joined:
    Mar 2, 2008
    Messages:
    89
    Likes Received:
    1
    Device:
    iPod touch
    Ahh...I hate Apple. Why do they have to make the App Store, now I'm so confused. If anyone can help me, that would be very apperciated.


    Heres my "Setup"

    I have a iPod Touch, with V. 1.1.3.

    Now I'm so confused with this 1.1.4, 2.0 and all this stuff. I'm usually upto date with this stuff, but I haven't had the time, so I'm behind like 2 months.

    Questions.


    1. Should I be at 1.1.3, 1.1.4, or 2.0?

    2. When I go to "Installer" I see stuff that I think are from the Appstore, but I don't have the Appstore installed on my iPod. Is this because people "hacked" the apps from the Appstore and put it on Installer, so people like us can get it for free?



    Thanks!
  2. spoonforknife

    spoonforknife Retired Moderator

    Joined:
    Nov 15, 2007
    Messages:
    6,896
    Likes Received:
    317
    1. You should be on 2.0.1. It is much more stable and a few killer apps are there or coming like Winterboard.

    2. Those cracked apps are not compiled for the 1.1.x firmwares, and I advise you not to download them due to their legality, but yes, that is the reason they are there.
  3. JOS

    JOS Member

    Joined:
    Jan 28, 2008
    Messages:
    522
    Likes Received:
    3
    Device:
    iPhone 5 (Black)
    ^^agreed.^^
  4. ubunix

    ubunix Member

    Joined:
    Aug 6, 2008
    Messages:
    637
    Likes Received:
    1
    Device:
    iPhone 5 (Black)
    2.0.1 yep yer pretty behind

Share This Page