Not Compatible

Discussion in 'iTunes App Store Games & Apps' started by xDarknerOx, Dec 31, 2008.

  1. xDarknerOx

    xDarknerOx Banned

    Joined:
    Dec 30, 2008
    Messages:
    78
    Likes Received:
    0
    Some games like Aurora Feint say "This app is not compatible with this Ipod." is there a problem with my ipod? It's a 2G, do I need to upgrade my software. Sorry I just got it two days ago and I have no clue about how this device works.
  2. Functional Disorder

    Functional Disorder New Member

    Joined:
    Dec 7, 2008
    Messages:
    703
    Likes Received:
    0
    Device:
    iPod touch
    Do you have the latest iTunes?
    Are you on FW 2.2?
    If both are not the most recent updates, could and should be the only reason.
  3. BaseballMVP755

    BaseballMVP755 Banned

    Joined:
    Dec 1, 2008
    Messages:
    624
    Likes Received:
    0
    u probably just need to upgrade..

Share This Page