Noob question!!!! ??

Discussion in 'iPod touch Firmware 3.0' started by omarzizo, May 27, 2009.

  1. omarzizo

    omarzizo New Member

    Joined:
    Feb 21, 2009
    Messages:
    76
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    hello, please everybody clear my misunderstand!!!

    i have iPod touch 2g and my device has been activated by a developer guy

    now the question is do i need to pay also when the os 3.0 reale or not

    Please Register or Log in to view images

    !!!

    it's not because the 10 $

    Please Register or Log in to view images

    it's nothing

    Please Register or Log in to view images

    but why to pay if it's already ok

    Please Register or Log in to view images

    ....??
  2. Chicken

    Chicken Retired Moderator

    Joined:
    Feb 17, 2008
    Messages:
    2,494
    Likes Received:
    7
    Device:
    iPhone 5S
    Because what you only have a "beta" version of the firmware. The "final" will probably contain features/bug fixes, that are not in the previous beta. The beta's may also be "timebombed" where after a certain amount of time it will force you to pay for the final version of 3.0 or revert back to 2.2.1
  3. RoYaLx

    RoYaLx Member

    Joined:
    Mar 11, 2009
    Messages:
    939
    Likes Received:
    22
    Device:
    HTC One
    I think you need a new beta version of iTunes to even SYNC it now (v8.2? Correct me if I am wrong).
  4. pody08

    pody08 Member

    Joined:
    Mar 3, 2008
    Messages:
    254
    Likes Received:
    0
    Device:
    iPhone 5 (Black)
    you are correct. you need itunes 8.2 pre-release for 3.0 beta 4 and above

Share This Page