no one developon ipod 3.0...

Discussion in 'iOS Development' started by acca2o, Oct 17, 2009.

  1. acca2o

    acca2o New Member

    Joined:
    Sep 26, 2009
    Messages:
    51
    Likes Received:
    0
    Device:
    2G iPod touch
    No way to run my simple first application.
    No way to understand why.
    Not just here, but in the web.

    Is there someone that develop with the toolchain for 3.0 ipod firmware?

    Before signing with ldid my application the system kill it as it opens.
    After signing it with "ldid -S MyApp", it opens but closes after some second.

    What does it mean?
    I think ldid worked fine because the system doesn't kill the application as it opens. But anyway it closes in 3 seconds.

    And the yellow main window is not visible.
    I think the problem is that the system does not create the main window and so non runloop is started.
    But I read about this just in one post somewhere and no solution is avalable on the web.

    Please, help me to start developing, it's one week i try.
    Thanks
  2. Collateral

    Collateral Active Member

    Joined:
    Sep 23, 2007
    Messages:
    1,974
    Likes Received:
    6
    Device:
    iPhone 3GS (Black)
    Just to make sure, when using ldid, you dont literally type "MyApp", you type the name / path of your application
  3. acca2o

    acca2o New Member

    Joined:
    Sep 26, 2009
    Messages:
    51
    Likes Received:
    0
    Device:
    2G iPod touch
    yes...
    i.e. if my applicaton name id Pacman I go inside the directory /Applications/Pacman.app and there I use ldid -S Pacman
    for sure this operation change something because after the application died in some second and not immediatly.

    One question...is it the same to run the killall SpringBoard before or after the ldid command?
    is it right to set permission to 755 or better to 777?

    is there some way to get a log file from ipod or debug the application?

    thanks!!!
  4. Collateral

    Collateral Active Member

    Joined:
    Sep 23, 2007
    Messages:
    1,974
    Likes Received:
    6
    Device:
    iPhone 3GS (Black)
    You killall after the ldid command.

    and 755 is fine, but if you put it at 777 it doesnt matter
  5. acca2o

    acca2o New Member

    Joined:
    Sep 26, 2009
    Messages:
    51
    Likes Received:
    0
    Device:
    2G iPod touch
    so I did right, the problem is real

    Please Register or Log in to view images


    Do you think my application is signed? few seconds open means signed?
    I habe to understand where to look for the solution, but before where the problem is.

    1) the application is not signed
    2) the application is not right initalized
    3) something changed in firmware 3.0

    witch one?
    I posted the code on another post 2 days ago.
    Can you take a look there?
    Do you develop on 3.0 o 2.1?
  6. Collateral

    Collateral Active Member

    Joined:
    Sep 23, 2007
    Messages:
    1,974
    Likes Received:
    6
    Device:
    iPhone 3GS (Black)
    uhh yea ill look at your code.

    I develop on 3.X+ But i use the official SDK, not the toolchain
  7. ipodmail09

    ipodmail09 Member

    Joined:
    Mar 13, 2009
    Messages:
    269
    Likes Received:
    0
    Device:
    2G iPod touch
    the 3.0 SDK works only if you set the simulator-3.0 to Device - 2.0 and change Debug to release. shh the app and hay presto it works
  8. acca2o

    acca2o New Member

    Joined:
    Sep 26, 2009
    Messages:
    51
    Likes Received:
    0
    Device:
    2G iPod touch
    what about the toolchain cygwin?
    Can you pleasa show me the main.m, MyApp.m and MyApp.h that just create the main window and nothing more, generate from sdk for 3.0?
    Is it possible by sdk without using nibfile?

Share This Page