new using ipod touch

Discussion in 'iPod touch 1.1.x Jailbreak' started by yfz99, May 20, 2008.

  1. yfz99

    yfz99 New Member

    Joined:
    May 20, 2008
    Messages:
    1
    Likes Received:
    0
    i just bought a ipod touch 32gb 2 days ago and i heard about jailbreaking and it sounds cool when i wanted 2 do it i tried it wont work i have 1.1.3 version and i went to jailbreakme.com and when i tried installing it nothing came so wat should i have 2 do thanks for the help PS am new in ipods
  2. shotgunfool

    shotgunfool Active Member

    Joined:
    Oct 7, 2007
    Messages:
    1,233
    Likes Received:
    5
    Device:
    iPod touch
    you need to downgrade or upgrade
  3. yz85 rider

    yz85 rider Banned

    Joined:
    Feb 27, 2008
    Messages:
    471
    Likes Received:
    39
    Well i suggest using upgrading to 1.1.4 firmware and using Ziphone to jailbreak (simpleist and fastest). Go to the 1.1.4 jailbreak category to see guides on how to jailbreak
  4. Ricemast

    Ricemast New Member

    Joined:
    Dec 7, 2007
    Messages:
    15
    Likes Received:
    0
    Device:
    iPhone 3GS (White)
    Easy Jailbreak tut.

    Hi,
    there is a Jailbreaking tutorial on this website it is only the first installment but if you subscribe you will be notified when the next ones are realesd. it is usufull and easy to understand.

    anotherblog DOT co DOT uk/category/ipod-touch-iphone/

    many thanks
    Ricemast
  5. nachos1010

    nachos1010 New Member

    Joined:
    May 7, 2008
    Messages:
    276
    Likes Received:
    0
    If you want to jailbreak your itouch using jailbreakme.com you have to be running firmware 1.1.1 or 1.1.2.
  6. sjmarshy

    sjmarshy New Member

    Joined:
    May 21, 2008
    Messages:
    163
    Likes Received:
    1
    iJailbreak works pretty well if using a mac, I used it my first time back on 1.1.1 but I believe it works on 1.1.4 now...so yes, do as everyone else says and upgrade lol.

Share This Page