need some help

Discussion in 'iPhone' started by tweeder, Jul 25, 2010.

  1. tweeder

    tweeder New Member

    Joined:
    Dec 27, 2007
    Messages:
    24
    Likes Received:
    0
    My niece is her on holidays with her iphone 3g on 3.0.1. Her phone is unlocked when she got it and was told by her new provider that if it gets locked, they will not unlock it as it wasn't bought from them. She got the phone like that and she has cydia on there so i assume its also jailbroken. She can't add new songs as she needs to update it to a newer version but can't for fear of locking it.
  2. peebrian202869

    peebrian202869 Banned

    Joined:
    Nov 28, 2009
    Messages:
    2,061
    Likes Received:
    1
    Device:
    3G iPod touch
    I think she can only go as high as 3.1.3 to remain unlocked, do not attempt to upgrade as you will be forced to 4.0
  3. shashanknegi

    shashanknegi Active Member

    Joined:
    Feb 26, 2010
    Messages:
    1,778
    Likes Received:
    11
    Device:
    3G iPod touch
    i thought ultrasn0w was updated for the 3.1.3 baseband.
  4. peebrian202869

    peebrian202869 Banned

    Joined:
    Nov 28, 2009
    Messages:
    2,061
    Likes Received:
    1
    Device:
    3G iPod touch
    Sorry, yeh i think i was wrong... edited.
  5. J-Phone

    J-Phone Active Member

    Joined:
    Dec 1, 2009
    Messages:
    4,868
    Likes Received:
    10
    Device:
    iPhone 4 (Black)
    Just use iTunes 9 and don't update anything. If she still needs to unlock add blackra1n.com as a repo and download blacksn0w from there to unlock if needed.
  6. ripply

    ripply Active Member

    Joined:
    Jul 31, 2009
    Messages:
    1,159
    Likes Received:
    2
    Device:
    iPhone 4 (Black)
    Ultrasn0w works with the 4.0 and I think the 4.0.1 BB too
  7. CmD100

    CmD100 New Member

    Joined:
    Jul 26, 2010
    Messages:
    5
    Likes Received:
    0
    that is terrble! definitely return it

Share This Page