need older customize

Discussion in 'iOS Jailbreak & Cydia' started by BShep1305, Feb 19, 2008.

  1. BShep1305

    BShep1305 New Member

    Joined:
    Dec 8, 2007
    Messages:
    4
    Likes Received:
    0
    Device:
    2G iPod touch
    does anyone have a source for the older customize. because the current one i try downloading says i need firmware 1.1.3, or should i just upgrade to 1.1.3
    thank you

Share This Page