Need help with Wiki2Touch

Discussion in 'iPod touch Firmware 2.X' started by EriqueSherman, Oct 16, 2009.

  1. EriqueSherman

    EriqueSherman New Member

    Sep 7, 2008
    Likes Received:
    iPhone 3G (White)
    I've spent most of today trying to get Wiki2Touch to work properly on my iPhone 3G with firmware 2.2.1. I'm really curious to know if anyone got Wiki2Touch to work on their 2.2.1 (or 2.X perhaps) device recently and how they did it. I've read every tutorial/forum post I can find on the topic, but most posts are more then a year old and the links they refer to are often broken. I get confused about what I should do, as some of the instructions I've seen are for older fw and some for more recent fw and nothing of it seems to work for me.
    I've mainly followed this guide so far:, but when I make a search it only says "Article not found".

    Here is what I've done. If anyone think they have an idea about what I might be doing wrong, please point it out for me!
    1. Installed Wiki2touch server on Cydia.
    2. Downloaded latest english Wikipedia dump:
    3. Indexed it with the transfer tool (I got it from http://www.[].com/?d=IC6SMQ64 because all other links I could find didn't work)
    4. When I tried to upload the .bin-file with transfer tool I got an error message that said I either didn't have the right permissions set or I didn't have the correct directory. I've tried setting permissions to 0755 but it still won't let me upload this way. I'm however a bit unsure exactly for which files the permissions need to be changed. Instead I used i-funbox to move my indexed .bin-file to mobile/Media/Wikipedia/en.
    5. After this I rebooted and made sure the Wiki2Touch switch was set to "on" in SBSettings but when I search for something I doesn't find anything.

    I'm also confused about whether I should have a springboard icon for it or not. I didn't get one when I installed the server from Cydia, but it seems older versions of Wiki2Touch had one so I don't know what to expect.
    I've also tried the same steps with a dump of the swedish Wikipedia (because its much smaller and easier to work with) but still nothing happens.

    Here are some things I've thought up that might have something to do with my problem, but I don't know really:
    1. I have read that I should download "Wiki2Touch srvd" from Cydia, but the one I find hasn't got that exact name. It's called "Wiki2Touch server" but I suspect it is the same.
    2. Some guides say I should make Apache work with PHP, I don't know anything about that but the newer guides don't mention it so I assumed I didn't have to bother with it.
    3. I don't know if I should do anything with the folder mobile/wikisrvd. No tutorial even mentions it but it contains a tiny articles.bin-file in a folder called "xx", and I'm thinkg maybe I should do something with it.
    4. Could it be that Wiki2Touch doesn't work with latest dumps of Wikipedia? Should I get an older dump instead?
    5. Could my Wiki2Touch transfer tool be too old? It's version 065, but I can't find a more recent version.

    I would be enormously delighted if someone would help me sort this out. It seems a lot of people have managed to make it work for them, so maybe I'm just doing some major mistake. I really want it to work!

Share This Page