Need help with my Repo!

Discussion in 'iOS Jailbreak & Cydia' started by Katryss, Jan 14, 2008.

?

Is anyone else stuck with issues like this?

Poll closed Feb 3, 2008.
  1. Yes

    4 vote(s)
    80.0%
  2. No

    1 vote(s)
    20.0%
  1. Katryss

    Katryss Member

    Joined:
    Sep 27, 2007
    Messages:
    203
    Likes Received:
    6
    Device:
    iPhone 5S
    Okay, so I'm building myself up an Installer source with apps either I've created or stuff for Customize.

    Got hold of some tutorials, muddled my way through most of the coding.

    I can get it to show up in Installer. I can get it to download.

    But, it won't install. I get a "Main script execution failed!" error.

    It's driving me nuts!

    Please Register or Log in to view images



    So, here's my site: http://tristanbooker.googlepages.com/repo.xml

    Here's the file I'm trying to get onto my iPod: http://tristanbooker.googlepages.com/facebook.zip

    Is there a possibility that it won't work because I've zipped the folder in Windows and it hasn't saved any permissions or could it be my coding?

    Any help would be greatly appreciated.

    Perhaps someone could use Unix to retain the 755 permissions whilst zipping it. Then PM me the new zip file.

    Please Register or Log in to view images

  2. bddckr

    bddckr Active Member

    Joined:
    Dec 2, 2007
    Messages:
    1,434
    Likes Received:
    18
    Device:
    iPhone 4 (Black)
    First, it's not:
    It's:
    If you want to extravt files from the zip DON'T USE a "/" at the beginning. If you DON'T use it installer will know to look inside the zip file.


    Anyway... In the next installer version it will be required to have a "hash" code in it. So get this code now and put it in everytime for every zip, otherwise your repo will be obsolete.

    And it won't work with windows' zipped zips. So just read this:
    http://www.ifans.com/forums/showthread.php?p=182533#post182533
  3. Katryss

    Katryss Member

    Joined:
    Sep 27, 2007
    Messages:
    203
    Likes Received:
    6
    Device:
    iPhone 5S
    Okay, so I got rid of the erroneous "/" in my code... without it I get a scripting error, with it it installs.
    I got it to finish installing, but it's not creating a directory called Facebook.app in the Applications directory, or copying any files over.

    Any ideas? I think it still may be the zip file. I'm going to try WinRAR again and see if that makes any difference.
  4. bddckr

    bddckr Active Member

    Joined:
    Dec 2, 2007
    Messages:
    1,434
    Likes Received:
    18
    Device:
    iPhone 4 (Black)
    Try what I wrote before:
    http://www.ifans.com/forums/showthread.php?p=182533#post182533

    Using WinRar won't work! Trust me, I did all this 1000 times...

    Please Register or Log in to view images


    Just make sure it extracts the right folders to the right places.

    Please Register or Log in to view images

  5. BlazeEdwin

    BlazeEdwin New Member

    Joined:
    Oct 9, 2007
    Messages:
    485
    Likes Received:
    1
    Device:
    iPhone 3GS (Black)
    Why people want to create repos....

    Don't try to create repo when you are not a professional - Blaze - Steve

    ZIPPED FILES IN WINDOWS WILL NEVER WORK!
  6. bddckr

    bddckr Active Member

    Joined:
    Dec 2, 2007
    Messages:
    1,434
    Likes Received:
    18
    Device:
    iPhone 4 (Black)
    I agree, but there wouldn't be so much professionals if we thought like that...
  7. Katryss

    Katryss Member

    Joined:
    Sep 27, 2007
    Messages:
    203
    Likes Received:
    6
    Device:
    iPhone 5S
    Blaze, how is it any concern of yours if i want to make my own private repo?

    I don't think ANYONE can be called a professional when it comes to this sort of stuff.

    Did it occur to you that i may be trying this to learn?

    Unless you have anything constructive to add... keep it to yourself.

    Please Register or Log in to view images

  8. BlazeEdwin

    BlazeEdwin New Member

    Joined:
    Oct 9, 2007
    Messages:
    485
    Likes Received:
    1
    Device:
    iPhone 3GS (Black)
    sorry, I just got pissed off by someone

    Please Register or Log in to view images

    (my friend)

    But that's Steve's word, not mine

    Please Register or Log in to view images



    find SkylarEC, he is the best one to get answers (But still I don't get mine)
  9. bddckr

    bddckr Active Member

    Joined:
    Dec 2, 2007
    Messages:
    1,434
    Likes Received:
    18
    Device:
    iPhone 4 (Black)
  10. Katryss

    Katryss Member

    Joined:
    Sep 27, 2007
    Messages:
    203
    Likes Received:
    6
    Device:
    iPhone 5S
    Good news!!!
    Got it to download/install AND show up in the Springboard. It launches no probs!

    Thanks for the help!

    Now, next step is to add more than just one thing to it

    Please Register or Log in to view images

Share This Page