Need help with ipod touch 2g

Discussion in 'iPod touch' started by Isten, Oct 1, 2009.

  1. Isten

    Isten New Member

    Joined:
    Oct 1, 2009
    Messages:
    1
    Likes Received:
    0
    Device:
    2G iPod touch
    I want to upgrade my ipod from 2.2.1 to 3.0 , my ipod is not jailbroken.
    I brought it like a week ago , so i dont know much about it.

    I downloaded firmware 3,0 and shift+ rewstores i used that fail and it gave me that error:

    Please Register or Log in to view images

    It says: The Ipod "sten" could not be restored because the firmware file is not compatible.
    Can any1one please help me?

    and also i have 1 more question how can i install games on my ipod?
  2. boomer678

    boomer678 Member

    Joined:
    Jun 20, 2009
    Messages:
    425
    Likes Received:
    0
    Device:
    3G iPod touch
    Buy it from itunes and you wont have this problem

Share This Page