Need help with cydia

Discussion in 'iOS Jailbreak & Cydia' started by flipskater1092, Jan 17, 2009.

  1. flipskater1092

    flipskater1092 New Member

    Sep 13, 2008
    Likes Received:
    Whats up everyone? I have a 1st gen 8gb touch running 2.1 firmware jailbroken. Ive run into a few small problems in the past but I was able to fix everything that's previously happened.

    About an hour ago, I was attempting to install a source in cydia (we'll leave the source nameless, but I will tell you it was [PIRACY]us involved) and about halfway through the install, cydia just sh*t out and closed. this has happened in the past, and I'm not sure why exactly it does this, but I brushed it off. I think it might be because I needed to install the mobileinstallation patch first, but I'm not 100% on that. Anyway, I tried to go back and install that patch, and cydia just crashed on me again right as the home page was loading, but before it finished updating the release.gprs (or whatever it is). I tried and tried again to open cydia and had the same thing happen every time. it crashes right after the main cydia homepage loads, even when I don't touch the screen at all.
    I tried to respring, reboot, and boot into safe mode, all to no avail. it just keeps crashing at the same point. I also tried deleting some app store apps to free up ram and that didn't seem to help either.

    I have no access to a computer whatsoever, so re-jailbreaking isn't an option for me at all. Is there any kind of terminal command or anything I can do to fix this problem? Maybe a way to uninstall and reinstall cydia directly from my iPod? Im accepting all options and suggestions right now, as I'd like to take care of this ASAP.

    If someone could let me know why cydia crashes when trying to install certain sources, that would be helpful as well. I've been curious (and furious at times) about that.

    One more thing. Im not sure how I did it or what I installed to cause it to happen, but where it once said "iPod" in the top left corner, it now says "no service", which pops up after it says "searching", then a pop up saying "this may take some time", which I click "dismiss" on everytime. I have MakeItMine installed, and I had it saying something else before, but I've tried changing the text with no success. I can still change the banner, but not the carrier. Any idea how to fix this?
  2. Sarcasm Siempre

    Sarcasm Siempre New Member

    May 9, 2008
    Likes Received:
    iPod touch
    Open Mobile Terminal.

    Type the following:

    su root
    alpine (won't show up when you type it, don't worry)
    apt-get remove cydia
    Yes, do as I say!
    apt-get install cydia

Share This Page