Must I upgrade?

Discussion in 'iPod touch Firmware 2.X Jailbreak' started by MikeonTV, Aug 6, 2008.

  1. MikeonTV

    MikeonTV New Member

    Joined:
    Apr 28, 2008
    Messages:
    16
    Likes Received:
    0
    Device:
    iPhone
    I have an 8GB iPod Touch. 1.1.4 and I'm loving it. It is jailbroken and I am happy with all my current apps. But I am starting to notice new apps in the appstore (I've never connected the ipod to the app store).

    My question is, can I access the apps without upgrading and thus jailbreaking again, or do I have to go through it all over again and debug yet another version of the firmware?

    I SHH to my ipod sometimes and I know how to get at my files and current apps. Can I restore them using FTP again after the upgrade?
  2. rockbBAndGOD666

    rockbBAndGOD666 New Member

    Joined:
    Aug 6, 2008
    Messages:
    2
    Likes Received:
    0
    No you must upgrade and jailbreak again but the 2.0 jailbreak is great i reccomend it and the apps from the app store are great to (But a little pricey) i say upgreade and jailbreak
  3. MikeonTV

    MikeonTV New Member

    Joined:
    Apr 28, 2008
    Messages:
    16
    Likes Received:
    0
    Device:
    iPhone
    It says I have to pay to get the update to 2.0.1!!

    WTF? why would I do that? Also I see that there are alot of apps at the app store.
  4. Zee

    Zee Member

    Joined:
    Oct 11, 2007
    Messages:
    633
    Likes Received:
    2
    Device:
    iPhone 4 (Black)

    The apps in the appstore will only work on firmware 2.0 or higher. Also your current apps that you've gotten on jailbroken 1.1.4 will NOT work on 2.0 or higher (until the original developers port those apps)

    Up to you on what you want to do.
  5. MikeonTV

    MikeonTV New Member

    Joined:
    Apr 28, 2008
    Messages:
    16
    Likes Received:
    0
    Device:
    iPhone
    So do we have the ability to get apps on 2.x.x that are not availible at the appstore?
  6. andydam

    andydam Banned

    Joined:
    Sep 17, 2007
    Messages:
    348
    Likes Received:
    0
    You don't have to upgrade.
  7. soccerpro100cn

    soccerpro100cn New Member

    Joined:
    Dec 26, 2007
    Messages:
    598
    Likes Received:
    0
    Device:
    iPhone 3G (Black)
    Where have u been for the last month? Of course 2.x.x will cost money, as you have to pay 10$ to get the base 2.0 software if u haven't upgraded yet.
  8. Zee

    Zee Member

    Joined:
    Oct 11, 2007
    Messages:
    633
    Likes Received:
    2
    Device:
    iPhone 4 (Black)
    2.0 is jailbroken and you can install apps not available on app store. 2.0.1 jailbreak isn't released yet but when it is the same applies as above.
  9. thechungster

    thechungster Super Moderator Emeritus

    Joined:
    Dec 8, 2007
    Messages:
    6,886
    Likes Received:
    4
    Device:
    iPhone 4 (Black)
    you don't have to upgrade, but i recommend it seeing how more and more apps are being ported day by day

Share This Page