Music and Videos not playing and no sound

Discussion in 'iPod touch' started by Pieman1013, Oct 27, 2010.

  1. Pieman1013

    Pieman1013 Guest

    Hi All,

    I'm really hoping someone can help me. I have an Apple iPod 2g 16gb.

    I am having real problems with the sound not working when I upgrade the firmware. If I update to the new 4.1, the internal speaker stops working completely and that's not all...

    If I try to play a song, it basically loads the PLAYING screen (with the two arrows and PLAY button in the middle at the bottom) then appears to immediately stop the song and go back to the track list screen.

    Also... whenever I try playing any videos on the youtube app, it keeps saying video cannot be played...

    Now, if I downgrade to Firmware version 2.1.1 sounds works, videos work and music plays!

    I have tried all the Restore option and Reset all settings solution and nothing seems to work. I have been researching like mad on the Internet and have found a couple of posts with similar problesm so I know it isn't just me but does anyone have any ideas at all because, had I any, I'd have ripped all my hair out by now!!!
  2. humanidt

    humanidt Member

    Joined:
    Feb 22, 2009
    Messages:
    579
    Likes Received:
    0
    Device:
    4G iPod touch
    try restoring your device... through iTunes i mean.
  3. Tried restore - no joy!

    I have tried restoring it from within itunes; it made no difference. However, I am shocked that I appear to be one of only a few people that have experienced the problem unless it is being described differently by others.
  4. Hurr Durr

    Hurr Durr Banned

    Joined:
    Oct 21, 2010
    Messages:
    258
    Likes Received:
    0
    Device:
    2G iPod touch
    Obviously a complex issue, have you tried unsyncing everything off your iPod, then syncing it back on? Usually iTunes will report any errors in audio/video compatability.

    If all else, do a DFU restore and send it to Apple if it's still under warranty.
  5. Pieman1013

    Pieman1013 Guest

    Hi Hurr Durr...

    Very complex. I really can't fathom it! I have done a DFU Restore (that's how I managed to get 2.1.1 back on to the iPod). It's almost as if the latest firmware is messing up the audio/video codecs and speaker setting. The music is definitely on the ipod because I can play it off my ipod frm within itunes.

    Unfortunately, it is no longer under warrantee so I can't send it back to Apple otherwise I'd have done it straight away because this thing is driving me crazy! I can use it as just a music player on 2.1.1 or as an apps player on 4.1 but I can't use it as both on either (most of the apps need a later firmware than 2.1.1 to run!)

    I'm so frsustrated!
  6. Hurr Durr

    Hurr Durr Banned

    Joined:
    Oct 21, 2010
    Messages:
    258
    Likes Received:
    0
    Device:
    2G iPod touch
    Forgive me, you say this is only music and video app doing this? Maybe you can SSH music.app and video.app from 2.1.1 and replace the ones on 4.1? It might work, but make sure you backup first if you try it.


    Im not sure about locations unfortunately, someone else will have to say them

    Please Register or Log in to view images

  7. Pieman1013

    Pieman1013 Guest

    Tests

    OK...

    After much experimentation, I have managed to try a number of different firmwares. Here are the results:

    Firmware Sound Videos Apps

    2.1.1 Yes Yes Not many
    2.2.1 Yes Yes Not many
    3.0 Yes Yes Not many
    4.0 No No Yes
    4.1 No No Yes


    I can't get 3.1.2 or 3.1.3 on to my ipod no matter what I do; it took a while to figure out a work around to getting some of the other older firmwares on to my ipod.

    If anyone knows anyway of getting 3.1.3 on my iPod touch, it would help as I believe many of the apps are compatible with this firmware version! As it stands, I'm stuck on 3.0 but poor app compatibility!

    Any suggestions?
  8. Unregistered

    Unregistered Guest

    Same

    Let me no if sumone fixes this problem I have the same issue
  9. cmagana88

    cmagana88 New Member

    Joined:
    Nov 7, 2010
    Messages:
    2
    Likes Received:
    0
    Device:
    3G iPod touch
    thats exactly whats happening to me ive tried restoring it and it still does the same thing
  10. Unregistered

    Unregistered Guest

    OMG I HAVE THE SAME PROBLEM. Someone really needs to fix this please. Restore doesn't work at all and I don't know what to do. Video's don't even work either, does yours work???

Share This Page