Monopoly Question

Discussion in 'iTunes App Store Games & Apps' started by ipodtouchesrule, Feb 9, 2009.

  1. ipodtouchesrule

    ipodtouchesrule Active Member

    Joined:
    Jan 5, 2008
    Messages:
    1,009
    Likes Received:
    10
    Device:
    iPhone 4 (Black)
    When i tried downloading Monopoly: Here & Now. It says "Not compatible with iPod Touch." I was wondering if anyone else was getting this message.

    Thanks.
  2. Uniquedot

    Uniquedot New Member

    Joined:
    Mar 6, 2008
    Messages:
    158
    Likes Received:
    0
    Device:
    iPod touch
    Try upgrading firmware.
  3. NeSEncHo

    NeSEncHo Active Member

    Joined:
    Jul 16, 2008
    Messages:
    1,322
    Likes Received:
    0
    MONOPOLY Here & Now : The World Edition on the App Store requires iPhone 2.2 Software Update. I see from your devices panel, that you are on an iPod Touch 2.0. Please update to software version 2.2.1.
  4. Mr Monopoly

    Mr Monopoly Member

    Joined:
    Jan 19, 2009
    Messages:
    391
    Likes Received:
    0
    Device:
    iPhone 4S (Black)
    You need to update

Share This Page