MobiTV not compatible with my ipod touch?

Discussion in 'iTunes App Store Games & Apps' started by JadaSki, Apr 14, 2010.

  1. JadaSki

    JadaSki Member

    Joined:
    Jan 3, 2010
    Messages:
    553
    Likes Received:
    13
    Device:
    4G iPod touch
    i have an ipod touch 2g 3.1.2 jailbroken and when i try to download mobiTV from itunes on my mac it says its not compatible? why is that?
  2. Fieryfear

    Fieryfear New Member

    Joined:
    Apr 4, 2010
    Messages:
    224
    Likes Received:
    0
    Device:
    3G iPod touch
  3. J-Phone

    J-Phone Active Member

    Joined:
    Dec 1, 2009
    Messages:
    4,868
    Likes Received:
    10
    Device:
    iPhone 4 (Black)
    It may need a higher firmware(3.1.3) or is for the iPhone only
  4. JadaSki

    JadaSki Member

    Joined:
    Jan 3, 2010
    Messages:
    553
    Likes Received:
    13
    Device:
    4G iPod touch
    Might be iPhone since fiery is on 3.1.3

Share This Page