Managing iTunes!!

Discussion in 'iTunes' started by nomentalgiant, Nov 9, 2007.

  1. nomentalgiant

    nomentalgiant New Member

    Joined:
    Nov 4, 2007
    Messages:
    2
    Likes Received:
    0
    Sometimes when I import files into iTunes, I can't get the songs on an album to group together. For example, if there are 14 tracks on the album, iTunes will display 14 separate copies of that album with only one song on each copy. This phenomenon appears to be completely random and it is very frustrating. It takes forever to browse my music this way and slow up the computer a bit as well. Is there a way I can drag and drop these songs where I want them or any other suggestions? Thanks for your help.

    -James
  2. AutoItKing

    AutoItKing New Member

    Joined:
    Oct 26, 2007
    Messages:
    264
    Likes Received:
    1
    Try highlighting all of the songs in that album and using the info box to change the album to the same thing. Then press ok. That should work.
  3. partyboy911

    partyboy911 New Member

    Joined:
    Oct 15, 2007
    Messages:
    187
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    For like a soundtrack with many artists, I use the "album artist" option in the info.
  4. lachlan438

    lachlan438 Member

    Joined:
    Sep 16, 2007
    Messages:
    329
    Likes Received:
    0
    Device:
    iPhone 3G (Black)
    highlight them all then go compilation (yes) that works for me

Share This Page