Major Problem!

Discussion in 'iOS Jailbreak & Cydia' started by Jibblejab, May 10, 2010.

  1. Jibblejab

    Jibblejab New Member

    Joined:
    Apr 4, 2009
    Messages:
    357
    Likes Received:
    0
    Device:
    2G iPod touch
    Well sorta...

    My mate was fiddling with a firmware spoofer application on my ipod and spoofed my firmware to 3.1.3 and then back to 3.0. But it doesnt say 3.0 (8X54) or whatever it just says 3.0() which now means i am unable to download cydia apps that require 3.0.

    Ive tried and i cant find the firmware spoofer again. Any ideas what to do?

    Please Register or Log in to view images

  2. kid_chris_cool

    kid_chris_cool New Member

    Joined:
    Apr 4, 2009
    Messages:
    42
    Likes Received:
    0
    Device:
    2G iPod touch
  3. Jibblejab

    Jibblejab New Member

    Joined:
    Apr 4, 2009
    Messages:
    357
    Likes Received:
    0
    Device:
    2G iPod touch
    I tried it, but because of my... predicament it wont let me download.

    There is a file you can edit by SSH im just not sure what or where
  4. NinetyFour

    NinetyFour Active Member

    Joined:
    Jul 31, 2009
    Messages:
    1,736
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    And what is ur predicament, exactly?
  5. Jibblejab

    Jibblejab New Member

    Joined:
    Apr 4, 2009
    Messages:
    357
    Likes Received:
    0
    Device:
    2G iPod touch
    Cydia wont recognise that im using 3.0 which means i cant download a lot of stuff i need
  6. Jibblejab

    Jibblejab New Member

    Joined:
    Apr 4, 2009
    Messages:
    357
    Likes Received:
    0
    Device:
    2G iPod touch
    Really sorry for the bump but does anyone have any suggestions or the .deb for the firmware spoofer?
  7. Volcomstone000095

    Volcomstone000095 Banned

    Joined:
    Nov 23, 2009
    Messages:
    262
    Likes Received:
    1
    Device:
    3G iPod touch
    Some of the apps have dependencies based off of firmware version, Cydia cannot read his.
  8. Gatorsxrule

    Gatorsxrule New Member

    Joined:
    Nov 24, 2009
    Messages:
    275
    Likes Received:
    0
    Device:
    3G iPod touch
    Can you download iFile/openSSH?
    if you can browse to /system/library/coreservices and open up SystemVersion.plist and then change it from there
  9. narwal13

    narwal13 Active Member

    Joined:
    Oct 12, 2009
    Messages:
    3,070
    Likes Received:
    6
    Device:
    5G iPod touch
    Gatorsxrule's method works, I've done it to fix it when stupid FWChanger wouldn't change anything.

    But, you can just use iFunbox/DiskAid instead of iFile/OpenSSH
  10. Jibblejab

    Jibblejab New Member

    Joined:
    Apr 4, 2009
    Messages:
    357
    Likes Received:
    0
    Device:
    2G iPod touch
    Yep found the plist file, not sure which bit to edit. Sorry I sound like a right noob

    Please Register or Log in to view images



    EDIT: Sorted

Share This Page