Main Script Execution Failed - posted a hundred times

Discussion in 'iOS Jailbreak & Cydia' started by canadianL00S3R, Apr 14, 2008.

  1. canadianL00S3R

    canadianL00S3R New Member

    Joined:
    Apr 11, 2008
    Messages:
    6
    Likes Received:
    0
    So ok, before anyone starts yelling and gets pissed off... I did the following things:

    Hey, i did all these steps, and i looked through multiple forums about this problem but still no luck. My installer was working perfectly fine, i installed a couple of applications and all of a sudden it stops working. I tried the

    chmod 4755 /Applications/Installer.app/Installer

    command but it keeps telling me this

    chmod: /Applications/Installer.app/Installer: Operation not permitted

    I still get the main script execution error... Anyone can help? I really am tired of restoring and jailbreaking all the time.

    P.S. I already move my applications folder (for the space issue) when i first jailbroke the ipod so i dont run out of space.. the installer still worked but like i said after a while it stopped working.. can't install or uninstall anything

    I am running jailbroken 1.1.4 - please anyone I'm really tired of the same old =>

    Clean your queue and read other posts responses because i did and still nothing
  2. optimo

    optimo New Member

    Joined:
    Sep 28, 2007
    Messages:
    535
    Likes Received:
    17
    power-down and reboot the device
    or
    hard-quit Installer by holding home-key for 7 seconds

    then try Installer again


    what I want to know is how far you got before this error started appearing. you must have installed a few items before it craps out.
  3. iPod_SAge

    iPod_SAge New Member

    Joined:
    Feb 28, 2008
    Messages:
    132
    Likes Received:
    2
    Try

    cd /
    cd Applications/
    chmod +s Installer.app/Installer
    chown -R root:wheel Installer.app

    It worked for me.
  4. canadianL00S3R

    canadianL00S3R New Member

    Joined:
    Apr 11, 2008
    Messages:
    6
    Likes Received:
    0
    I tried that already.. but every time I try to use the chmod I get

    chmod: /Applications/Installer.app/Installer: Operation not permitted

    so I can't even try any of that because it won't let me.

    Yea I tried to reboot and hard-quit the installer, but every time the story is the same... everything works fine, I install a few applications (do that whole thing and put the applications on another partition) then install some more applications. After a while it works fine but then it starts giving me Main script execution failed. I tried to uninstall things yesterday and it actually uninstalls programs.. just never installs anything.
  5. stromboli1994

    stromboli1994 New Member

    Joined:
    Jan 28, 2008
    Messages:
    178
    Likes Received:
    1
    Device:
    iPod touch
    have you tried going to the uninstall tab in installer, and then scrolling down to installer and hitting "reinstall"?
  6. canadianL00S3R

    canadianL00S3R New Member

    Joined:
    Apr 11, 2008
    Messages:
    6
    Likes Received:
    0
    yea i just did... but the same thing happens as if i try to install things... it gives me Main script execution error. I tried to reinstall BSD subsystem and the installer but same thing. I'm really tired of restoring the ipod .. any other ideas anyone?
  7. canadianL00S3R

    canadianL00S3R New Member

    Joined:
    Apr 11, 2008
    Messages:
    6
    Likes Received:
    0
    I found that for some reason I cannot chmod for other applications or folders. I read an article on the secure level of the kernel for freeBSD and it said if the secure level is set to 1 chmod won't work even when logged in as root. I checked and the level for my iPod is 1, but when I try to change it the same error appears: Operation not permitted... Anyone has any ideas?
  8. maraca2020

    maraca2020 New Member

    Joined:
    Feb 5, 2008
    Messages:
    444
    Likes Received:
    3
    just wondering, is this happening to everybody or only some people? Because im having the same problem
  9. Loudmouth2332

    Loudmouth2332 Member

    Joined:
    Dec 25, 2007
    Messages:
    436
    Likes Received:
    4
    Device:
    iPod touch
    it jsut started happening to me after working ok for the first few downloads after a fresh JB
  10. maraca2020

    maraca2020 New Member

    Joined:
    Feb 5, 2008
    Messages:
    444
    Likes Received:
    3
    Sry to sound like a noob but thats in terminal, Right?

Share This Page