[Mac Only] Downgrade 3.0 to 2.2.1

Discussion in 'iPod touch Firmware 3.0' started by MacPwn, Jun 16, 2009.

  1. MacPwn

    MacPwn Banned

    Joined:
    Jun 9, 2009
    Messages:
    138
    Likes Received:
    0
    [Mac Only] Downgrade 3.0b to 2.2.1

    iPhone, iPhone 3g, and iPod touch 1g: Put your device into DFU mode and option-click restore with your 2.2.1 firmware. (NOTICE: if you own an iPod touch 2g, you can do this same method as well, but the one below can be used to restore with a custom firmware)

    iPod touch 2g:

    First, you will need redsn0w lite. (rslite)

    Click here to download redsn0w lite

    Second, you will need libusb.

    Click here to download libusb

    Put the "rslite" folder on your desktop and don't change its name.

    Open up "Terminal" by searching with spotlight:

    Please Register or Log in to view images



    Copy and paste the following commands into terminal
    (Don't forget to press enter after each command)

    Code:
    cd ~/Desktop/rslite
    Code:
    ./rslite
    Code:
    !ibss211.dfu
    Code:
    ./rslite
    Code:
    #pwn211ibss.txt
    Code:
    !ibss221pwn.dfu
    Your iPod's screen should be white.

    You can now restore your iPod in iTunes with ANY type of firmware excluding NOR only firmwares.
  2. jordskee

    jordskee Member

    Joined:
    Apr 28, 2008
    Messages:
    681
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    it doesnt let me downgrade my first gen to 2.2.1 it just get errors
  3. Axis

    Axis Super Moderator Staff Member

    Joined:
    Dec 2, 2007
    Messages:
    6,288
    Likes Received:
    133
    Device:
    iPhone 4S (White)
    Make sure you are actually in DFU mode.

    Step 1. Turn off your iPhone.

    Step 2. Hold down the power and home button.

    Step 3. When you see the Apple logo, release the power button but continue holding the home button down.

    Step 4. Open iTunes and wait for it to tell you that its in restore mode.

    *Plug iPhone in first.
  4. veeloc

    veeloc New Member

    Joined:
    Sep 6, 2008
    Messages:
    815
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    i just keep getting error 20 as soon as it is done extracting FW, it goes straight to error 20!! then i have to restore to 3.0.
  5. Axis

    Axis Super Moderator Staff Member

    Joined:
    Dec 2, 2007
    Messages:
    6,288
    Likes Received:
    133
    Device:
    iPhone 4S (White)
    You aren't in DFU mode. The screen should be blank, not with an iTunes logo. Wait about 1-2 seconds after the the device turns off then release the power button.
  6. veeloc

    veeloc New Member

    Joined:
    Sep 6, 2008
    Messages:
    815
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    ive always had trouble with DFU

    Please Register or Log in to view images

    always....
  7. Zaxarotl

    Zaxarotl New Member

    Joined:
    Dec 13, 2008
    Messages:
    1
    Likes Received:
    0
    i accidentually upgraded to the Beta 3.0.
    i tried a lot of times, and i have the same message again, and again.. error 1604
    Will i have to wait for the os 3.0 software for my first generation ipod touch?
  8. pyroxp7

    pyroxp7 Active Member

    Joined:
    Aug 3, 2008
    Messages:
    344
    Likes Received:
    69
    Device:
    iPhone 5 (White)
    I think what also may contribute to the many errors is that you may have th lastest version of iTunes installed. I'm going to try to uninstall the latest version of iTunes and install the previous versions and downgrade. If it works, I'll post here telling you people.
  9. Axis

    Axis Super Moderator Staff Member

    Joined:
    Dec 2, 2007
    Messages:
    6,288
    Likes Received:
    133
    Device:
    iPhone 4S (White)
    No, you need 8.2 to work with 3.0. I've been on iTunes 8.2 since it came out and I have downgraded successfully three times, once for myself, twice to prove that it could be done easily.
  10. kaizersix

    kaizersix New Member

    Joined:
    Mar 12, 2009
    Messages:
    24
    Likes Received:
    0
    Device:
    iPhone 3G (Black)
    i guess libusb is needed.. can you confirm this? i tried it and on the ./rslite command, it says:

    dyld: Library not loaded: /usr/local/lib/libusb-0.1.4.dylib
    Referenced from: /Users/kurt/Desktop/rslite/./rslite
    Reason: image not found
    Trace/BPT trap

Share This Page