linux deleted my vista boot loader!?

Discussion in 'Linux' started by tktouch12, May 25, 2009.

  1. tktouch12

    tktouch12 Member

    Joined:
    Jan 21, 2009
    Messages:
    349
    Likes Received:
    0
    Device:
    iPhone 4S (Black)
    i tried to install vista to my portable hard drive using wubi. what it did was installed the operating system to my portable hard drive, but installed the GRUB bootloader onto my hard drive and deleted my vista boot loader (from my computer). So, my vista (which is on my computer hard drive) can't boot without having my portable hard drive plugged in. how can i fix this? and how can i install to a portable next time and not get this problem? thanks
  2. wibble

    wibble New Member

    Joined:
    Mar 16, 2008
    Messages:
    176
    Likes Received:
    0
    "linux" didn't delete anything; you did.
  3. tktouch12

    tktouch12 Member

    Joined:
    Jan 21, 2009
    Messages:
    349
    Likes Received:
    0
    Device:
    iPhone 4S (Black)
    Yes ok I know
    but is there a way to get it back? Or will I hav to repartition and start over?
  4. fckinfamous

    fckinfamous Well-Known Member

    Joined:
    Sep 17, 2008
    Messages:
    1,954
    Likes Received:
    26
    Device:
    iPhone 5S
  5. Mortel

    Mortel Active Member

    Joined:
    Dec 6, 2007
    Messages:
    1,272
    Likes Received:
    13
    Device:
    3G iPod touch
    Boot into a Windows CD, and get into the Recovery Console.
    Use the "fixmbr" command.

    This should delete grub and replace it with the Windows bootloader.
  6. tktouch12

    tktouch12 Member

    Joined:
    Jan 21, 2009
    Messages:
    349
    Likes Received:
    0
    Device:
    iPhone 4S (Black)

Share This Page