Leopard 10.5.2 update and iTunes 7.5

Discussion in 'iPod touch' started by skrambol, Feb 11, 2008.

  1. skrambol

    skrambol New Member

    Joined:
    Feb 2, 2008
    Messages:
    6
    Likes Received:
    0
    My iTunes is still 7.5 and dont want to upgrade to 7.6 . If I install the Leopard 10.5.2 update, will iTunes 7.5 still work or do i have to update it also to the latest version? Thanks.
  2. skrambol

    skrambol New Member

    Joined:
    Feb 2, 2008
    Messages:
    6
    Likes Received:
    0
    The reason that I dont want to update my iTunes is because I heard stories not able (or having difficulties) to downgrade their iPod Touch using the latest iTunes version

Share This Page