Kept getting connect to itunes logo, tried to restore now my touch is dead!! Help!!!

Discussion in 'iPod touch' started by johnydangerous, Sep 4, 2009.

  1. johnydangerous

    johnydangerous New Member

    Joined:
    Sep 4, 2009
    Messages:
    3
    Likes Received:
    0
    Device:
    iPod touch
    Hi guys, have a huge headache i can't seem to get around. I own a ipod first gen 16gb that was running version 1.1 or 2, my itunes was updated to version 8.2 last week. I tried to purchase the version 3 software for the touch from apple, as i did it downloaded it to itunes. My ipod was connected to itunes during the download, and it was working. Once the upload began i walked out the room and on my return i saw a error msg saying it could not complete the upload of the firmware, i found my ipod with the connect to itunes logo. I then tried to do the restore which i have done before, after a few attempts the computer recognised the ipod was attached and a bar showed up in itunes saying waiting for ipod, a min or so later a error msg came up saying unable to complete dis connect ipod and try again. I did so and itunes never recognised it. I attempted to do the restore again holding the home button and power button, but now my ipod wont even turn onto anything not even the itunes connect logo. Tried to charge it but nothing works.

    Please if anyone can help, i would be greatful
  2. carfreak95

    carfreak95 Member

    Joined:
    Nov 25, 2008
    Messages:
    548
    Likes Received:
    0
    Device:
    iPod touch
    Try dfu mode.

Share This Page