Jailbroken iPod Touch vs Game compatibility

Discussion in 'iOS Jailbreak & Cydia' started by reinhart_menken, Apr 28, 2009.

  1. reinhart_menken

    reinhart_menken New Member

    Joined:
    Apr 28, 2009
    Messages:
    20
    Likes Received:
    0
    Hiya,

    I'm considering buy an iPod touch for use as a casual break-time gaming, e-book reading device and general PDA function device. I'm going to jailbreak it, of course, but I'm a bit concerned about application compatibility with different versions of jailbroken iPod OS (OS X?).

    During my "research" of various iPod touch games and programs I read that certain programs only support certain versions of jailbroken iPod touch (unless I read it wrong). So, I was wondering if applications and games on iPod touch are 1-fits-all (at least have backward compatibility to older versions, if not requiring newer version), or is it like certain computer game mod where you'll need a specific version of the update just to run a certain mod - sometimes even requiring you to use older update just to play a mod. And yes, I know games/apps are different from pc game mods, but my lack of understanding of how jailbreaking works has led me to such concern.

    Pretty much - I need to know that the iPod touch that I'll buy and jailbreak will play as many games as I'll want to justify the spending.

    Thanks!

    ps. Sorry if this has been asked before!

    ps2. I don't want a PSP. Just in case anyone might be so "wise" to suggest that.
  2. DNJ45

    DNJ45 New Member

    Joined:
    Feb 24, 2009
    Messages:
    244
    Likes Received:
    0
    Device:
    2G iPod touch
    All app store apps will work if you buy a iPod touch with 2.0 or higher. Some older 3rd party games might not work on the latest 2.x jailbreak. There aren't that many 3rd party games, so you will probably getting them from the App Store.

    Basically, you'll have access to thousands of games, that should be enough.
  3. mikec1985

    mikec1985 Active Member

    Joined:
    Dec 22, 2007
    Messages:
    2,558
    Likes Received:
    0
    Device:
    iPad
    Any thing on the app store will work with firmware 2.2.1, which is the latest firmware. In iTunes in the app description look under requirements and it will tell you what is needed to use the game/app.
  4. reinhart_menken

    reinhart_menken New Member

    Joined:
    Apr 28, 2009
    Messages:
    20
    Likes Received:
    0
    Thanks a lot!

Share This Page