Jailbroken iPod Restore

Discussion in 'iOS Jailbreak & Cydia' started by whitesoup12, Dec 29, 2009.

  1. whitesoup12

    whitesoup12 New Member

    Dec 29, 2009
    Likes Received:
    iPod touch
    Hello All!

    Okay, here's the deal... I have a first generation iPod Touch 8Gb that I jailbroke using Blackrain. I noticed that no matter how long I left it plugged in to the charger, the battery would still give me a 20% remaining warning. Also, a "USB Unkown Device" error constantly came up, not allowing me to sync with iTunes. No wanting to deal with the "quirks" of a jailbroken iPod, I decided to restore it. Since it would not show in iTunes, I initiated the restore from the settings menu on the iPod. The restore process completed, but the iPod is stuck on the Apple boot up screen. I tried holding home and sleep buttons down until reboot about 10 different times and 20 different ways, none of which worked. I've tried restarting the service in administration tools, and I've tried re-installing the driver (and iTunes) multiple times. I'm running out of options here, as I've tried just about everything I could find. Any help would be much appreciated!
    ------------------double post merged------------------
    Figured it out... It was the cable...

    Please Register or Log in to view images

Share This Page