Jailbreaking iPod Touch 2G problem

Discussion in 'iPod touch Firmware 2.X Jailbreak' started by wormxeaten, Apr 11, 2009.

  1. wormxeaten

    wormxeaten New Member

    Joined:
    Apr 11, 2009
    Messages:
    2
    Likes Received:
    0
    Hello everyone!
    I have an iPod Touch 2G 8GB.
    I want to JailBreak it and I've downloaded all the needed software for it (QuickPwn & the IPSW file).
    The software version of the iPod it 2.2.1 and I restored all setting throught iTunes before I've began JB.
    Now, Ive started the QuickPwn program and everything went fine 'till the moment when it asked for the IPSW file.
    When I choose the file it says:
    "The IPSW file you selected does not match any firmware version QuickPwn supports. Either the IPSW file is corrupted, or the firmware version is unsupported."
    What can I do? Please help.
  2. Mr Monopoly

    Mr Monopoly Member

    Joined:
    Jan 19, 2009
    Messages:
    391
    Likes Received:
    0
    Device:
    iPhone 4S (Black)
    Download The ipsw file again?
  3. wormxeaten

    wormxeaten New Member

    Joined:
    Apr 11, 2009
    Messages:
    2
    Likes Received:
    0
    yes, i downloaded the latest version and it's not corrupted...
    ------------------double post merged------------------
    i think the problem is that the 2G is just not supported yet... am i right?
  4. Hams

    Hams New Member

    Joined:
    Feb 10, 2009
    Messages:
    14
    Likes Received:
    0
    Device:
    2G iPod touch
    2G is fully supported by the latest beta of QuickPWN.
  5. jlgm25

    jlgm25 Well-Known Member

    Joined:
    Nov 1, 2008
    Messages:
    3,302
    Likes Received:
    28
    Device:
    4G iPod touch
    No. Quickpwn released a beta version that supports 2G iPods

Share This Page