iOS 3.1 Jailbreaking from iPod Touch 2G FW 2.2.1 to 3.1.1

Discussion in 'iOS Jailbreak & Cydia' started by Skarian, Dec 24, 2009.

  1. Skarian

    Skarian New Member

    Joined:
    Aug 30, 2009
    Messages:
    11
    Likes Received:
    0
    Device:
    2G iPod touch
    Ok i have a jailbroken iPod touch 2G on FW 2.2.1 and i want to make that a Jailbroken iPod touch 2g on FW 3.1.1. Now how do i do that, im on a mac too.

    http://www.youtube.com/watch?v=KGIDJsTW3io

    will this work?? please help. ALSO I NEED IT UNTETHERED!!
  2. brendanm

    brendanm New Member

    Joined:
    Dec 17, 2008
    Messages:
    658
    Likes Received:
    0
    Device:
    iPhone 3G (White)
    you have an iPod Touch 2G, it's automatically going to be untethered.
    Here's what you do:

    1. Plug your iPod into iTunes and go to the iPod page in your left-hand panel on iTunes. Choose "Check for update" which will then prompt you to accept a user agreement I believe, and will start downloading the 3.1.2 firmware, and then automatically install it.

    2. While it's downloading, go to www.blackra1n.com and click the Mac logo, which will download this application for your Mac.

    3. When your iPod is done restoring, cancel the sync and go to your blackra1n program you just downloaded.

    4. Click "make it ra1n".

    5. Now your done, go to the blackra1n icon just added and install Cydia or Rock, or both if you wish. Get to business. At some point, re-sync your iPod so you get all your music, photos, video's and app's back onto your iPod.

    Best of luck,
    Brendan
  3. Skarian

    Skarian New Member

    Joined:
    Aug 30, 2009
    Messages:
    11
    Likes Received:
    0
    Device:
    2G iPod touch
    ok, thannk you so much man, is there anything else i need to know??
  4. brendanm

    brendanm New Member

    Joined:
    Dec 17, 2008
    Messages:
    658
    Likes Received:
    0
    Device:
    iPhone 3G (White)
    Nope, your set. Did you do this, and how'd it work?

    It's rather simple. Just make sure that when your downloading anything from Cydia or Rock or whatever app your using to download your content, that the item your downloading is compatible with 3.1.2.. Alright? Just read the description that's in the info, it'll state if it's not compatible with 3.1.2!

    Not trying to make you sound like an idiot, but you'll end up having to restore and could be stuck in a bad situation if you download something that's not intended for 3.1.2 or download an older version of something.. I've had this happen to me, and had my iPod Touch un-usable for several days until I was able to finally restore it. This is a rare situation, and no matter what you can always restore usually.

    If for some reason you don't like your jailbreak, or what you've done and want to go back to default. Plug into your PC, go to the iPod page in iTunes and click "Restore", and it'll set you right back to the stock firmware. Also do this if you have to send it away, for whatever reason, as while it is jailbroken it voids your warranty, but you get your warranty back in one quick restore, my friend.

    Merry Christmas,
    Brendan
  5. Skarian

    Skarian New Member

    Joined:
    Aug 30, 2009
    Messages:
    11
    Likes Received:
    0
    Device:
    2G iPod touch
    ok one last question, i cant install things intended for older vesions in cydia?? r most of the cydia apps tested with 3.1.2?? thanks for all the help!!
  6. SoBe

    SoBe Banned

    Joined:
    Sep 1, 2009
    Messages:
    3,788
    Likes Received:
    1
    Device:
    2G iPod touch
    the majority of them should work, unless they specifically say they're for older firmwares
  7. Skarian

    Skarian New Member

    Joined:
    Aug 30, 2009
    Messages:
    11
    Likes Received:
    0
    Device:
    2G iPod touch
    ok i did eveything successflly, End of Thread.

Share This Page