iOS 4.1 jailbreaking a 3rd gen ipod touch on 4.1

Discussion in 'iOS Jailbreak & Cydia' started by quicky, Sep 23, 2010.

  1. quicky

    quicky Member

    Joined:
    Sep 10, 2010
    Messages:
    30
    Likes Received:
    0
    C'mon I cant be the only one with this device. users already on 4.1 with 3g ipod touches need a jailbreak too!
  2. hacker123

    hacker123 Banned

    Joined:
    Sep 23, 2010
    Messages:
    28
    Likes Received:
    0
    Device:
    iPhone 3G (Black)
    do u hav shsh for 4.0
  3. quicky

    quicky Member

    Joined:
    Sep 10, 2010
    Messages:
    30
    Likes Received:
    0
    Nope, that's why it's kind of stupid that a downgrade should be a pre-requisite for a jb!
  4. hacker123

    hacker123 Banned

    Joined:
    Sep 23, 2010
    Messages:
    28
    Likes Received:
    0
    Device:
    iPhone 3G (Black)
    then u hav to waittttttt
  5. Dalton63841

    Dalton63841 Active Member

    Joined:
    Sep 9, 2010
    Messages:
    888
    Likes Received:
    100
    Device:
    iPhone 4 (Black)
    LOL Don't feel bad...I have a 3rd gen iPod Touch. I have saved every shsh blob since I got it, but since I never had 3.1.2, no Snowbreeze for me...Still, Im sitting tight on 4.0, so its not too bad...

    Just take this as a lesson learned, always back up your blobs!
  6. hacker123

    hacker123 Banned

    Joined:
    Sep 23, 2010
    Messages:
    28
    Likes Received:
    0
    Device:
    iPhone 3G (Black)
    ya man same here mine also came with 3.1.3
  7. swisstony

    swisstony New Member

    Joined:
    Sep 21, 2010
    Messages:
    17
    Likes Received:
    0
    Device:
    3G iPod touch
    Big learning curve, we will screw up on that learning curve, but then thats what makes us b3tter than b4.

    good innit?

    swisstony
  8. quicky

    quicky Member

    Joined:
    Sep 10, 2010
    Messages:
    30
    Likes Received:
    0
    I bought this ipod long after 3.1.2 so its not like I could've backed up the shsh stuff anyway. Also I was kind of hoping a much BETTER jb would come along which doesnt need u to downgrade to jb 4.1 - this cant be the only jb coming for 4.1 (cuz it seems pretty crappy. lots of errors for ppl, and ofc it doesnt even jb an ipod touch properly)
  9. Dalton63841

    Dalton63841 Active Member

    Joined:
    Sep 9, 2010
    Messages:
    888
    Likes Received:
    100
    Device:
    iPhone 4 (Black)
    Well the new jb, based on the shatter exploit, hasn't been released yet. It is a bootrom exploit that will jb everything, without downgrading.

    When it is released there will be a huge announcement, so just sit tight.
  10. quicky

    quicky Member

    Joined:
    Sep 10, 2010
    Messages:
    30
    Likes Received:
    0
    really? Okay if that is true then cool beans man. Just makes me wonder why even bother release 'this' jb when a much better one is coming out anyway? Seems like a rush job.

Share This Page