iOS 4.0 Jailbreaking 3G[S] MB

Discussion in 'iOS Jailbreak & Cydia' started by curtisk, Jun 24, 2010.

  1. curtisk

    curtisk Member

    Joined:
    Apr 9, 2008
    Messages:
    190
    Likes Received:
    6
    Device:
    iPhone 5 (Black)
    Hi,

    I've just been given a 3GS off my dad (he's just got the iPhone 4) which was previously JB'd at 3.1.3 using Sn0wbreeze (SHSH on file for 3.1.3 only)

    I wanted to upgrade to 4, so i found some custom ipsw's on the web. I tried to use these, but it kept hanging and failing during the restore process.

    Anyway, i thought it might be a good idea to upgrade to the stock firmware first - what a mistake that has turned out to be!

    Now whenever i try to restore to th custom firmware i get error 1600.

    Is there any way of jailbreaking the phone now or is it going to be non-jailbreakable?

    JUST TO CONFIRM - IT IS DEFINITELY A MB MODEL!

    Thanks in advance guys
    Curtis

    EDIT: I just realized this is in the wrong forum - it was intended to go into the JB forum - can a mod please move it?
  2. LastChaosBeast

    LastChaosBeast New Member

    Joined:
    Jun 16, 2010
    Messages:
    369
    Likes Received:
    0
    Device:
    2G iPod touch
    Restore to 3.1.2 is you want to go back.

    If you want to jailbreak, use redsn0w.
  3. curtisk

    curtisk Member

    Joined:
    Apr 9, 2008
    Messages:
    190
    Likes Received:
    6
    Device:
    iPhone 5 (Black)
  4. b-mac 39

    b-mac 39 Well-Known Member

    Joined:
    Dec 15, 2009
    Messages:
    5,809
    Likes Received:
    60
    Device:
    iPhone 4S (White)
    Use redsn0w. It works on MB models.
  5. curtisk

    curtisk Member

    Joined:
    Apr 9, 2008
    Messages:
    190
    Likes Received:
    6
    Device:
    iPhone 5 (Black)
    Right thanks for the replies.

    Im still stick but here are the facts:

    * I have SHSH blobs on cydia for 3.1.3 ONLY
    * Redsn0w only works on 3.1.2
    * I should not of upgraded to the clean firmware as this upgrades the bootrom.

    Im guessing the only J/B-able bootrom is on firmware 3.1.2.

    I would very much like to have iOS4 J/B. Is it possible do you think or am i basically f**ked? haha
  6. b-mac 39

    b-mac 39 Well-Known Member

    Joined:
    Dec 15, 2009
    Messages:
    5,809
    Likes Received:
    60
    Device:
    iPhone 4S (White)
    Redsn0w works on 4.0, 3.1.3, 3.1.2, basically everything. Bootrom can't change, BTW. It's hardware.
  7. curtisk

    curtisk Member

    Joined:
    Apr 9, 2008
    Messages:
    190
    Likes Received:
    6
    Device:
    iPhone 5 (Black)
    redsnow 0.9.4 and 0.9.5 beta do not support 3.1.3
  8. b-mac 39

    b-mac 39 Well-Known Member

    Joined:
    Dec 15, 2009
    Messages:
    5,809
    Likes Received:
    60
    Device:
    iPhone 4S (White)
    Oh. So it works for 4.0 only then. Oh well, other redsn0ws have supported it.
  9. curtisk

    curtisk Member

    Joined:
    Apr 9, 2008
    Messages:
    190
    Likes Received:
    6
    Device:
    iPhone 5 (Black)
    redsn0w supported 3.1.2 and 4, but not 3.1.3

    After research, if you have shsh blobs for 3.1.2 you are jailbroken for life, but 3.1.3 patches it.

    As i dont have the ability to install 3.1.2 it looks like it stuffed

    Please Register or Log in to view images

    !!!
  10. b-mac 39

    b-mac 39 Well-Known Member

    Joined:
    Dec 15, 2009
    Messages:
    5,809
    Likes Received:
    60
    Device:
    iPhone 4S (White)
    No, since you have an MB model, you are jailbroken for life.

Share This Page