Jailbreaking 1G ipod touch 8GB (1.1.5)

Discussion in 'iPod touch' started by :blacKOut:, Mar 19, 2009.

  1. :blacKOut:

    :blacKOut: New Member

    Joined:
    Mar 19, 2009
    Messages:
    2
    Likes Received:
    0
    Hey guys, after having my ipod touch for about 15 months, i decided it would be nice to jailbreak it. Now, I jailbroke it with ziphone and everything went fine; however, I could only download iCopter and thats it. I restored it and downgraded to 1.1.4 and then I jailbroke it with ziphone again but I still could not get any apps onto my ipod touch.
    Right now, its fully restored with 1.1.5 firmware and has no music or anything on it. I want to upgrade to 2.2.1 (Or whichever one is the best???) but i believe I need to upgrade to 2.0 first. Is this true??
    Once I upgrade, I want to know how to jailbreak it and I want to be able to download basically any app I want. What do I do? What program do I use? How do I know what apps I will be able to download? Could any of you guys direct me to a link or give me some infor that would be able to help me jailbreak it?
    Also, I tried searching but could not find a thread that was similar to my problem. And I lack knowledge in this area and any help would be great. Thanks.
  2. jhloa2

    jhloa2 Member

    Joined:
    Feb 11, 2008
    Messages:
    714
    Likes Received:
    3
    Device:
    iPhone 4 (Black)
    I dont think you need to go to 2.0 first.

    After you upgrade, download quickpwn (search the forum) and follow the instructions.

    It is really easy once you get the hang of it

    P.S Don't try to use ziphone once you upgrade
  3. :blacKOut:

    :blacKOut: New Member

    Joined:
    Mar 19, 2009
    Messages:
    2
    Likes Received:
    0
    Thanks man.

    Also, I have the firmware but I am still unsure how to upgrade (I thought I knew). I believe I need to do that Shift + Check for Update thing but I am not sure. I will be searching the forums for the answer but if you know, posting the answer will be awesome. Thanks.

    Edit: I hope its all right to ask that question....
    ------------------double post merged------------------
    Alright, I fail at updating to 2.2.1. I had to restore my ipod touch four times...Any tips? Also, do I need the latest itunes with quickpwn?
  4. Sarcasm Siempre

    Sarcasm Siempre New Member

    Joined:
    May 9, 2008
    Messages:
    1,836
    Likes Received:
    0
    Device:
    iPod touch
    The latest iTunes (8.1) is not necessary, but is recommended. And don't click Shift + Check for Upgrade, click Shift (or Option if you're on a Mac) + Restore.

Share This Page