Jailbreak or Wait?

Discussion in 'iPod touch 1.1.4 Jailbreak' started by Cryto, Jul 1, 2008.

  1. Cryto

    Cryto New Member

    Joined:
    Jun 30, 2008
    Messages:
    24
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    Well this is my 1st day on these forums and I feel like I have learned alot. My main question now concerns FW 2.0 for the touches. I do not yet own one, but plan on picking one up in the near future. Will apple come out wit ipods wit the software following july 11 or not? Also, as far as jailbreaking... would it be better to have a 1.1.4 jailbroken or normal 2.0 wit app store. Do you have to pay for apps and are themes limited? Any help would be much appreciated. Thanks!!!
  2. awal

    awal Well-Known Member

    Joined:
    Jan 2, 2008
    Messages:
    4,764
    Likes Received:
    31
    Device:
    iPhone 4S (White)
    Yes, after July 11, iPods will come with 2.0 pre-installed (just like with the January Update). If you decide to go with 2.0 (which I recommend as jailbreaking gets old kinda quick) you may as well wait until then. As for themes, no they are not limited at all for jailbroken iPods. There are so many that you end up wasting way too much time trying to decide on one.
  3. Cryto

    Cryto New Member

    Joined:
    Jun 30, 2008
    Messages:
    24
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    Ya I know there not limited on jailbroken ipods, but was wondering if there available on an unbroken touch with 2.0
  4. stirpicus

    stirpicus New Member

    Joined:
    Dec 25, 2007
    Messages:
    48
    Likes Received:
    0
    No, themes are only available for jailbroken iPods with a firmware of 1.1.3 or earlier.
  5. malibusurfer93

    malibusurfer93 Banned

    Joined:
    Feb 21, 2008
    Messages:
    1,891
    Likes Received:
    4
    upgrade and wait for 2.0 to be jailbroken
  6. thechungster

    thechungster Super Moderator Emeritus

    Joined:
    Dec 8, 2007
    Messages:
    6,886
    Likes Received:
    4
    Device:
    iPhone 4 (Black)
    or you could wait on jailbroken 1.1.4. then see if 2.0 can be jailbroken. but if u want to stick on 2.0 anyway, just do it.

    im getting the iPhone, with 2.0

    so im having my touch for emulators and themes which i love.
    and iPhone for App store


    it is really ur choice
  7. awal

    awal Well-Known Member

    Joined:
    Jan 2, 2008
    Messages:
    4,764
    Likes Received:
    31
    Device:
    iPhone 4S (White)
    Um, themes work on 1.1.4, too.
  8. thechungster

    thechungster Super Moderator Emeritus

    Joined:
    Dec 8, 2007
    Messages:
    6,886
    Likes Received:
    4
    Device:
    iPhone 4 (Black)
    ahh!! im still not sure what to do! upgrade to 2.0 for my iPod. OR stick with 1.1.4, and get an iPhone. but i dont have enough money yet.
  9. Cryto

    Cryto New Member

    Joined:
    Jun 30, 2008
    Messages:
    24
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    I think I am just going to stick to a 1.1.4 ipod, but then have the option to upgrade if I really want. Plus, I bet 2.0 will be jailbroken at some point.

Share This Page