jailbreak for the 1.1.2 version?

Discussion in 'iPod touch 1.1.x Jailbreak' started by macmaniac, Dec 11, 2007.

  1. macmaniac

    macmaniac New Member

    Joined:
    Dec 10, 2007
    Messages:
    1
    Likes Received:
    0
    Hi,

    I have a iPod Touch with firmware version 1.1.2. I want to installl a VPN client , and I guess that I need the "jailbreak" , but will it work?

Share This Page